Microsoft Excel

Herbers Excel/VBA-Archiv

mit INDIREKT() arbeiten | Herbers Excel-Forum


Betrifft: mit INDIREKT() arbeiten von: Peter
Geschrieben am: 09.12.2009 08:02:08

Guten Tag

Ich scheitere beim Versuch, in untenstehender Formel die 3 x 09 mit einem INDIREKT-Bezug auf die Zelle G3 zu ersetzen. In Zelle G3 steht die Zahl 2009, womit rechts(G3;2) zu 09 führt.

Wer kann mir weiterhelfen?

Danke , Peter

=SUMMENPRODUKT((Mitarbeiter_09=$A11)*(Monat_09=G$1)*Betrag_09)

  

Betrifft: AW: mit INDIREKT() arbeiten von: fcs
Geschrieben am: 09.12.2009 08:41:19

Hallo Peter,

=SUMMENPRODUKT((INDIREKT("Mitarbeiter_" & RECHTS($G$3;2))=$A11)*
(INDIREKT("Monat_" & RECHTS($G$3;2))=G$1)*INDIREKT("Betrag_" & RECHTS($G$3;2)))

Gruß
Franz


  

Betrifft: AW: mit INDIREKT() arbeiten von: Peter
Geschrieben am: 09.12.2009 09:02:27

Hallo Franz
Das ist perfekt!
Vielen Dank, Peter


Beiträge aus den Excel-Beispielen zum Thema "mit INDIREKT() arbeiten"