Microsoft Excel

Herbers Excel/VBA-Archiv

Akkumulations Grenzwert beeinflusst Berechnung | Herbers Excel-Forum


Betrifft: Akkumulations Grenzwert beeinflusst Berechnung von: Frank
Geschrieben am: 12.12.2009 05:28:58

Hi,
ich berechne eine Summe per Monat in der einen Spalte A und kumuliere die Summen in einer anderen Spalte B.
Jetzt aber muss ich die Berechnung in Spalte A auch davon abhaengig machen wenn Spalte B einen Gernzwert

erreicht.

Genauer gesagt, in Spalte A berechne ich die Kommission per Monat u. in Spalte B akkumuliere ich die

Kommission ... wenn die akkumulierte Kommission einen Grenzwert erreicht muss die Berechnung in Spalte A

gewaehrleisten dass die Kommissionsberechnung in Spalte A so gestaltet ist dass in Spalte B als akkumulierter

Betrag der Grenzwert nicht ueberschritten wird.

Ich weiss nicht wie man das macht, kann mir jemand helfen ?

  

Betrifft: AW: Akkumulations Grenzwert beeinflusst Berechnung von: robert
Geschrieben am: 12.12.2009 07:48:26

hi,

ich denke so etwa:

wenn summe in B kleiner grenzwert,
dann rechne in spalte A,

wenn grenzwert erreicht ist, keine berechnung in A

bei excel-gut solltest du das lösen können

gruß
robert


  

Betrifft: AW: Akkumulations Grenzwert beeinflusst Berechnung von: Frank
Geschrieben am: 12.12.2009 08:46:16

... ja ist mir auch logisch aber ich habe einen Knoten im Kopf dass sich das gegenseitig beeinflusst ... aber eigentlich muesste das doch auch ohne Iteration gehen ... habe mal eine Mini Kalkulation angehaengt ... https://www.herber.de/bbs/user/66544.xls


Gruss,
Frank


  

Betrifft: AW: Akkumulations Grenzwert beeinflusst Berechnung von: Daniel
Geschrieben am: 12.12.2009 08:50:53

hi
wie hoch soll denn in zeile 7 die Kommission sein? 0 oder 405, damit genau 1000 als Summierte Kommission rauskommt?
ansonsten Schau dir mal die MAX-funktion an, vielleicht kommst du damit weiter.

Gruß, Daniel


  

Betrifft: AW: Akkumulations Grenzwert beeinflusst Berechnung von: Frank
Geschrieben am: 12.12.2009 09:02:52

... ja in Zeile 7 muesste die Kommision dann 496-91 sein, damit in B7 1000 bei rauskommt ... MAX ja irgendwie, aber MAX was ?? Der Groschen faellt bei mir noch nicht in die MAX Richtung ... ich denke andauernd noch if(Kumuliert>Grenzwert,(kumuliert-Grenzwert)*-1 ... u. das irgendwie abziehen von Kommission ... aber da verknotet es sich bei mir auch schon ...


  

Betrifft: AW: Akkumulations Grenzwert beeinflusst Berechnung von: Daniel
Geschrieben am: 12.12.2009 09:16:14

Hi
wie wäre es in B5 mit folgender Formel: =Max(1000;Summe(c$5:C5)*$a$2)
Gruß, Daniel


  

Betrifft: AW: Akkumulations Grenzwert beeinflusst Berechnung von: Frank
Geschrieben am: 12.12.2009 10:20:49

... hm, da kommt dann bei mir 1000 raus ... u. wenn ich die Formel fuer die anderen Zellen in der Column auch benutze (Serie) dann klappt das auch nicht ...


  

Betrifft: AW: Akkumulations Grenzwert beeinflusst Berechnung von: hary
Geschrieben am: 12.12.2009 10:55:22

Hi Frank
evtl so als Ansatz.

Tabellenblattname: Sheet1

 

A

B

C

D

1

Kommission

Kumuliert

Sales

Kommission Grenzwert

2

10%

 

 

1.000

3

 

 

 

 

4

 

 

 

 

5

300

300

3.000

 

6

295

595

2.948

 

7

405

1.000

4.959

 

8

0

1.000

2.939

 

9

0

1.000

1.234

 


Benutzte Formeln:
A5: =C5*A$2
B5: =SUMME(A5;B3)
A6: =C6*A$2
B6: =SUMME(A6;B5)
A7: =(C7*A$2)-(MAX((B6+(C7*A$2));D2)-D2)
B7: =SUMME(A7;B6)
A8: =(C8*A$2)-(MAX((B7+(C8*A$2));1000)-1000)
B8: =SUMME(A8;B7)
A9: =(C9*A$2)-(MAX((B8+(C9*A$2));1000)-1000)
B9: =SUMME(A9;B8)
gruss hary


  

Betrifft: Akkumulations Grenzwert beeinflusst Berechnung von: robert
Geschrieben am: 12.12.2009 14:35:16

hi,

vielleicht so ?

gruß
robert
Tabellenblattname: Sheet1

 

A

B

C

D

1

Kommission

Kumuliert

Sales

Kommission Grenzwert

2

0,1

 

 

1000

3

 

 

 

 

4

 

 

 

 

5

300

300

3000

 

6

294,8

594,8

2948

 

7

405,2

1000

4959

 

8

0

1000

2939

 

9

0

1000

1234

 


Benutzte Formeln:
A5: =WENN((C5*$A$2)+B4<$D$2;C5*$A$2;$D$2-B4)
B5: =WENN(B4+A5>$D$2;$D$2;A5+B4)
A6: =WENN((C6*$A$2)+B5<$D$2;C6*$A$2;$D$2-B5)
B6: =WENN(B5+A6>$D$2;$D$2;A6+B5)
A7: =WENN((C7*$A$2)+B6<$D$2;C7*$A$2;$D$2-B6)
B7: =WENN(B6+A7>$D$2;$D$2;A7+B6)
A8: =WENN((C8*$A$2)+B7<$D$2;C8*$A$2;$D$2-B7)
B8: =WENN(B7+A8>$D$2;$D$2;A8+B7)
A9: =WENN((C9*$A$2)+B8<$D$2;C9*$A$2;$D$2-B8)
B9: =WENN(B8+A9>$D$2;$D$2;A9+B8)


  

Betrifft: AW: Akkumulations Grenzwert beeinflusst Berechnung von: Frank
Geschrieben am: 12.12.2009 18:33:55

Hi Leute,
yup, das Beispiel von Robert passt ganz genau ... ich hatte mich dabei verlaufen, dass ich konzeptionell nicht fuer beide Spalten (A + B) die Formeln gesucht habe.

Thx,
Frank


Beiträge aus den Excel-Beispielen zum Thema "Akkumulations Grenzwert beeinflusst Berechnung"