Microsoft Excel

Herbers Excel/VBA-Archiv

Formel zum addieren gesucht | Herbers Excel-Forum


Betrifft: Formel zum addieren gesucht von: Frank H.
Geschrieben am: 20.12.2009 17:00:48

Hallo zusammen,

ich vermerke in einer Datei die Mehrarbeit meiner Mitarbeiter. Neben der Stundenanzahl steht in der Zeile daneben, ob es sich um ein Minus oder ein Plus handelt.

Ganz unten rechne die GEsamtzeit zusammen. Derzeit allerdings händisch, weil ich nicht weiß, wie es sonst machen soll. Die Tabelle ist natürlich nur ein Ausschnitt. Es wird das gesamte Jahr eingetragen.

https://www.herber.de/bbs/user/66720.xls

Kann mir jemand helfen?

Viele Grüße
Frank

  

Betrifft: AW: Formel zum addieren gesucht von: Tino
Geschrieben am: 20.12.2009 17:11:38

Hallo,
geht es so?

 ABCDEFG
1 Mitarbeiter 1 Mitarbeiter 2 Mitarbeiter 3 
2 2:08Plus2:26Minus2:26Minus
3 6:15Minus4:30Minus10:00Plus
4       
5       
6       
7       
8       
9Gesamt4:07Minus6:56Minus7:34Plus

Formeln der Tabelle
ZelleFormel
B9=ABS(SUMMEWENN(C2:C8;"Plus";B2:B8)-SUMMEWENN(C2:C8;"Minus";B2:B8))
C9=WENN(SUMMEWENN(C2:C8;"Plus";B2:B8)-SUMMEWENN(C2:C8;"Minus";B2:B8)<0;"Minus";"Plus")
D9=ABS(SUMMEWENN(E2:E8;"Plus";D2:D8)-SUMMEWENN(E2:E8;"Minus";D2:D8))
E9=WENN(SUMMEWENN(E2:E8;"Plus";D2:D8)-SUMMEWENN(E2:E8;"Minus";D2:D8)<0;"Minus";"Plus")
F9=ABS(SUMMEWENN(G2:G8;"Plus";F2:F8)-SUMMEWENN(G2:G8;"Minus";F2:F8))
G9=WENN(SUMMEWENN(G2:G8;"Plus";F2:F8)-SUMMEWENN(G2:G8;"Minus";F2:F8)<0;"Minus";"Plus")


Gruß Tino


  

Betrifft: um beim 0:00 auch Plus anzuzeigen, ... von: Tino
Geschrieben am: 20.12.2009 17:23:13

Hallo,
wäre es sinnvoll das Ergebnis auf 8 Nachkommastellen zu runden.

 ABCDEFG
1 Mitarbeiter 1 Mitarbeiter 2 Mitarbeiter 3 
2 2:08Plus2:26Minus2:26Minus
3 6:15Minus4:30Minus10:00Plus
4 4:07Plus    
5       
6       
7       
8       
9Gesamt0:00Plus6:56Minus7:34Plus

Formeln der Tabelle
ZelleFormel
B9=ABS(SUMMEWENN(C2:C8;"Plus";B2:B8)-SUMMEWENN(C2:C8;"Minus";B2:B8))
C9=WENN(B9=0;"Plus";WENN(ABRUNDEN(SUMMEWENN(C2:C8;"Plus";B2:B8)-SUMMEWENN(C2:C8;"Minus";B2:B8); 8)<0;"Minus";"Plus"))
D9=ABS(SUMMEWENN(E2:E8;"Plus";D2:D8)-SUMMEWENN(E2:E8;"Minus";D2:D8))
E9=WENN(D9=0;"Plus";WENN(ABRUNDEN(SUMMEWENN(E2:E8;"Plus";D2:D8)-SUMMEWENN(E2:E8;"Minus";D2:D8); 8)<0;"Minus";"Plus"))
F9=ABS(SUMMEWENN(G2:G8;"Plus";F2:F8)-SUMMEWENN(G2:G8;"Minus";F2:F8))
G9=WENN(F9=0;"Plus";WENN(ABRUNDEN(SUMMEWENN(G2:G8;"Plus";F2:F8)-SUMMEWENN(G2:G8;"Minus";F2:F8); 8)<0;"Minus";"Plus"))


Gruß Tino


  

Betrifft: AW: Summewenn - summewenn owT owT von: hary
Geschrieben am: 20.12.2009 17:12:50

.


  

Betrifft: AW: Formel zum addieren gesucht von: Beate Schmitz
Geschrieben am: 20.12.2009 17:14:54

Hallo Frank,

 ABCDEFG
1 Mitarbeiter 1 Mitarbeiter 2 Mitarbeiter 3 
2482:08Plus2:26Minus2:26Minus
3496:15Minus4:30Minus10:00Plus
4       
5       
6       
7       
8       
9Gesamt4:07Minus6:56Minus7:34Plus

Formeln der Tabelle
ZelleFormel
B9=ABS(SUMMEWENN(C2:C8;"Plus";B2:B8)-SUMMEWENN(C2:C8;"Minus";B2:B8))
C9=WENN(SUMMEWENN(C2:C8;"Plus";B2:B8)>SUMMEWENN(C2:C8;"Minus";B2:B8); "Plus";"Minus")
D9=ABS(SUMMEWENN(E2:E8;"Plus";D2:D8)-SUMMEWENN(E2:E8;"Minus";D2:D8))
E9=WENN(SUMMEWENN(E2:E8;"Plus";D2:D8)>SUMMEWENN(E2:E8;"Minus";D2:D8); "Plus";"Minus")
F9=ABS(SUMMEWENN(G2:G8;"Plus";F2:F8)-SUMMEWENN(G2:G8;"Minus";F2:F8))
G9=WENN(SUMMEWENN(G2:G8;"Plus";F2:F8)>SUMMEWENN(G2:G8;"Minus";F2:F8); "Plus";"Minus")


Gruß,
Beate


  

Betrifft: Vielen Dank für die Hilfsbereitschaft... von: Frank H.
Geschrieben am: 20.12.2009 17:40:29

es klappt bestens. Damit habt Ihr mir eine mühsame Arbeit abgenommen.


Beiträge aus den Excel-Beispielen zum Thema "Formel zum addieren gesucht"