Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen aber richtig | Herbers Excel-Forum


Betrifft: Zählen aber richtig von: Steffi
Geschrieben am: 03.01.2010 13:58:59

Hallo Zusammen,

Erstmal ein Gutes Neues Jahr 2010

Nun mein Anliegen, es wurden 5 Bögen ausgeben, 5 wurden Zurückgeben.
1 davon Leer, das heißt nicht Ausgefüllt.

Nur in Zelle Y9 steht der Wert 4, richtig wäre Wert 5.

Ich bekomme das Rätsel nicht gelöst.

Gruß Steffi

Habe meine Datei beigefügt

https://www.herber.de/bbs/user/66945.xls

  

Betrifft: AW: Zählen aber richtig von: BoskoBiati
Geschrieben am: 03.01.2010 14:05:10

Hallo,

das ist doch kein Rätsel. Wenn Du nirgendwo ein "x" hast, dann ist für Excel der Fragebogen nicht da, daher steht in Y an der Stelle eine 0 und die Summe ist 4. Entweder Du trägst einmal ein "x" ein oder markierst auf andere Art, dass der Fragebogen da ist. Am besten eine Spalte, in der Du einträgst zurück und machst da ein "x" und zählst diese xe.

Gruß

Bosko


  

Betrifft: AW: Zählen aber richtig von: Steffi
Geschrieben am: 03.01.2010 14:34:52

Hallo Bosko,

in Einzelfällen kann man per Hand am Arm das Erledigen. Und da ich nicht bloß 5 Fragebögen zum Auswerten habe sondern einige mehr um genau zu sein 1000Stück, und ich keine möglichen Fehlerquellen einbauen möchte.

Du schreibst eine andere Art, wie meinst Du ??? Kannst Du mir ein Beispiel geben, wie Du es Lösen würdest.

DANKE

Gruß Steffi


  

Betrifft: =ANZAHL(Y3:Y8)..owT von: robert
Geschrieben am: 03.01.2010 14:06:47




  

Betrifft: AW: =ANZAHL(Y3:Y8)..owT von: Steffi
Geschrieben am: 03.01.2010 14:39:10

Hallo Robert,


die Formel =Anzahl(Y3:Y8)..owT funktioniert nicht.




Gruß Steffi


  

Betrifft: AW: =ANZAHL(Y3:Y8)..owT von: Hajo_Zi
Geschrieben am: 03.01.2010 14:42:52

Hallo Steffi,

was ist an dem Ergebnnis falsch?

Tabelle1

 XY
2Antw. 2 
3x1
4x1
5  0
6  1
7  1
8   
9  5
10   

verwendete Formeln
Zelle Formel
Y3 =WENN(ZÄHLENWENN(B3:X3;"x")>0;1;0)
Y4 =WENN(ZÄHLENWENN(B4:X4;"x")>0;1;0)
Y5 =WENN(ZÄHLENWENN(B5:X5;"x")>0;1;0)
Y6 =WENN(ZÄHLENWENN(B6:X6;"x")>0;1;0)
Y7 =WENN(ZÄHLENWENN(B7:X7;"x")>0;1;0)
Y9 =ANZAHL(Y3:Y7)

Tabellendarstellung in Foren Version 5.3



GrußformelHomepage


  

Betrifft: AW: =ANZAHL(Y3:Y8)..owT von: Steffi
Geschrieben am: 03.01.2010 14:50:56

Hallo Hajo,

das Ergebnis ist richtig, Sorry.

Wenn ich aber Fragebögen habe, die zwar Ausgegeben wurden aber nicht mehr zurückkamen.
Dann werden diese auch gezählt, und das darf nicht sein.

Gezählt werden soll folgendes:

- Alle die Ausgegeben wurden
- Alle die Zurückkamen Ausgefüllt
- Alle die nicht Ausgefüllt wurden
- Alle die nicht mehr Zurückkamen

Wahrscheinlich mein Fehler, hatte mich undeutlich Ausgedrückt. Sorry

Gruß Steffi


  

Betrifft: AW: =ANZAHL(Y3:Y8)..owT von: Hajo_Zi
Geschrieben am: 03.01.2010 14:54:46

Hallo steffi,

wo stehen diese Angaben in Deiner Tabelle?

Gruß Hajo


  

Betrifft: AW: =ANZAHL(Y3:Y8)..owT von: Steffi
Geschrieben am: 03.01.2010 14:58:55

Hallo Hajo,

in der Zelle Y1000 soll das Ergebnis stehen.

Falls das nicht Möglich ist, es gibt noch keinen festen Platz für das Ergebnis nehme jeden anderen Platz den Du mir vorschlägst das Problem zu lösen. Bin ganz offen für jeden Ratschlag.


Gruß und Danke

Steffi


  

Betrifft: AW: =ANZAHL(Y3:Y8)..owT von: Hajo_Zi
Geschrieben am: 03.01.2010 15:01:15

Hallo Steffi,

meinen Beitrag hast Du schon gelesen? Es macht sich iimmer gut, wenn Fragen beantwortet werden. Nach dem Wohin hatte ich nicht gefragt.

Gruß Hajo


  

Betrifft: AW: =ANZAHL(Y3:Y8)..owT von: fcs
Geschrieben am: 03.01.2010 15:44:02

Hallo Steffi,

was dir die anderen Helfer versucht haben klar zu machen ist:

Deine Tabelle enthält im Moment nicht genug Informationen, um leere Fragebögen von nicht zurückgegebenen Fragebögen unterscheiden zu können.

Du muss also in einer weiteren Spalte die Fragebögen kennzeichnen, z.b. durch X oder anders, die nicht zurückgekommen sind bzw. besser ein Eintrag J/N für Ja oder Nein. Dann kannst du auch vernünftig auswerten.

Gruß
Franz


  

Betrifft: AW: =ANZAHL(Y3:Y8)..owT von: Steffi
Geschrieben am: 03.01.2010 16:24:03

Hallo Franz,

jetzt Verstehe ich. Ich werde nochmals mich Hinsetzen und schreiben wie was ich gelöst haben möchte.


Kein Problem, Danke an alle Helfer einen schönen Sonntagabend

Eure Steffi


  

Betrifft: AW: =ANZAHL(Y3:Y8)..owT von: Steffi
Geschrieben am: 03.01.2010 16:24:10

Hallo Franz,

jetzt Verstehe ich. Ich werde nochmals mich Hinsetzen und schreiben wie was ich gelöst haben möchte.


Kein Problem, Danke an alle Helfer einen schönen Sonntagabend

Eure Steffi


  

Betrifft: ..immer das gleiche.. von: robert
Geschrieben am: 03.01.2010 15:04:51

undeutliche angaben, erst wenn der beitrag eine gewisse länge
erreicht hat, kommen die echten probleme und wünsche...

..ich mag das nicht..

gruß
robert


  

Betrifft: AW: ..immer das gleiche.. von: BoskoBiati
Geschrieben am: 03.01.2010 18:39:59

Hallo Robert,

wenn Du das nicht magst, dann äußere Dich doch nicht dazu. Die Aufgabe war von Anfang an klar und die Probleme daraus auch. Franz hat es genauso deutlich ausgedrückt, wie ich auch.

@Steffi,

wie ich am Anfang schon geschrieben habe, und andere nach mir auch, mach eine zusätzliche Spalte mit zurück, trage da ein, wenn ein Bogen zurück ist z.B. ein "x" und zähle diese Spalte.

Gruß

Bosko


  

Betrifft: ..werdie ich tun, aber.. von: robert
Geschrieben am: 03.01.2010 18:44:52

hi Bosko,

schau dir mal die "ausgangsfrage" an, bzw. dann den verlauf des beitrags.

da sind doch welten dazwischen..

vielleicht verstehst du dann, was ich meine :-)

gruß
robert


  

Betrifft: AW: ..werdie ich tun, aber.. von: Klaus
Geschrieben am: 03.01.2010 23:01:58

Hallo,



es ist irre wie man von einer Ausgangslage 1+1+0+1+1=4 richtig soll aber 5 sein, zu dieser Lösung zu kommen (siehe Teil2).



Gruß


  

Betrifft: AW: ..immer das gleiche.. von: robert
Geschrieben am: 03.01.2010 19:42:37

hi Bosko,

warum hast du darauf nicht geantwortet?

....wo doch alles so klar ist ?

gruß
robert


https://www.herber.de/forum/messages/1126853.html


  

Betrifft: AW: =ANZAHL(Y3:Y8)..owT von: Steffi
Geschrieben am: 03.01.2010 15:29:36

Hallo Hajo,

wo stehen diese Angaben in Deiner Tabelle? Nirgends.....

Im Text habe ich mein Anliegen aber beschrieben....

Gruß Steffi


  

Betrifft: AW: =ANZAHL(Y3:Y8)..owT von: Hajo_Zi
Geschrieben am: 03.01.2010 16:03:25

Hallo Steffi,

Danke für die Information. Ich habe in Excel noch nicht programmiert das Excel was aus dem Internet holen solll (aus Deinem Beitrag) ich kann Dir da nicht weiter helfen.

Gruß Hajo


  

Betrifft: ..kann nicht sein... owT von: robert
Geschrieben am: 03.01.2010 14:48:13




Beiträge aus den Excel-Beispielen zum Thema "Zählen aber richtig"