HERBERS Excel-Forum - das Archiv
zwei aktionen bei wenn Formel
Ralf

Hallo habe da ein problem und ich weiß nicht wie ich es anstellen soll :-(
Habe da eine Formel =WENN(F17="Schlechtwetter";H17-G16;"")
und ich möchte gerne Das wenn F17="Schlechtwetter" dann auch zelle J 17 leer ist also löschen
ich weiß gar nicht ob das geht vielleicht könnt ihr mir helfen
gruß ralf

AW: zwei aktionen bei wenn Formel
Klaus-Dieter

Hallo Ralf,
du kannst mit Zellfunktionen nur auf die Zelle einwirken, in der sich auch die Funktion befindet. Ich denke, das beantwortet deine Frage. Du brauchst also zwei Formeln.
Viele Grüße Klaus-Dieter

Online-Excel
AW: zwei Aktionen bei Wenn-Formel
Mike

Hey Ralf,
Und- / Oder-Aktionen kannst Du natürlich schon mit der Wenn-Formel abdecken,
in Deinem Fall müsstest Du aber einfach die Wenn-Formel in Zelle J17 auch definieren.
Gruss
Mike
AW: zwei Aktionen bei Wenn-Formel
Ralf

hallo
also mit und oder habe ich so noch gar keine erfahrung gemacht also in J 17 steht
=WENN(P17<0;P17;"")
also ich weiß nicht wie ich die zusammenbauen kann
gruß ralf
AW: zwei Aktionen bei Wenn-Formel
Mike

Hey Ralf,
müsste dann wohl so heissen:
=WENN(und(F17="Schlechtwetter"; P17<0); P17;"")
oder
=WENN(F17="Schlechtwetter"; ""; Wenn(P17<0); P17;""))
Gruss
Mike
AW: zwei Aktionen bei Wenn-Formel
Ralf

Also bei mir klappt es nicht keine von den beiden Formeln weiß auch nicht ob ich alles richtig mache
habe sie einfach in der zelle eingefügt kommt aber eine fehlermeldung
AW: zwei Aktionen bei Wenn-Formel
Ralf

geht das denn vielleicht per vba ?
also zb
wenn zelle f Schlechtwetter dann vier zelle weiter rechts ( J )inhalt löschen oder so ähnlich
un das soll ab spalte 16 gelten
AW: zwei Aktionen bei Wenn-Formel
Mike

Hey Ralf,
wenn in F Schlechtwetter herrscht, dann musst Du in der Spalte J definieren, dass "nichts"
rein kommt. Ohne VBA kannst Du dort nichts löschen.
Wenn es für weitere Spalten hinten gelten soll, dann gibts wiederum den Bezug zum F-Schlechtwetter.
in J: =wenn(f17="Schlechtwetter"; ""; J17*K17/360*12) *
* der hintere Teil der Formel "j17*.." ist nur als Beispiel gemeint.
Gruss
Mike
AW: zwei Aktionen bei Wenn-Formel
Ralf

Danke für deine Hilfe aber ich denke da muss VBA ran so komme ich nicht zu meinem gewünschten ergebnis
mit besten grüßen aus damme