Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Image
BildScreenshot zu Image Image-Seite mit Beispielarbeitsmappe aufrufen

Art.nr. formatieren | Herbers Excel-Forum


Betrifft: Art.nr. formatieren von: Tim
Geschrieben am: 06.01.2010 14:44:31

Liebe Forums-User,

ich habe ein Problem und fuer mich eine unloesbare Aufgabe.

Anbei ist eine Beispieldatei, in der das Problem erlautert wird:

https://www.herber.de/bbs/user/67013.xls

Vielen Dank fuer eure Hilfe!

Gruesse,

Tim

  

Betrifft: AW: Art.nr. formatieren von: Rudi Maintaire
Geschrieben am: 06.01.2010 15:01:35

Hallo,
Bearbeiten-Ersetzen; ~* durch nichts und dann Leerzeichen durch nichts.

Gruß
Rudi


  

Betrifft: =GLÄTTEN(WECHSELN(B2;"*";"")) ... von: Matthias L
Geschrieben am: 06.01.2010 15:05:32

Hallo Tim

Probier mal in Spalte C

=WENN(LÄNGE(B2)=8;B2;WENN(LÄNGE(B2)>8;GLÄTTEN(WECHSELN(B2;"*";""));""))
Gruß Matthias


  

Betrifft: Sorry, sollte zu Tim ... kwT von: Matthias L
Geschrieben am: 06.01.2010 15:06:33




  

Betrifft: AW: Art.nr. formatieren von: Klaus-Dieter
Geschrieben am: 06.01.2010 15:04:23

Hallo Tim,

jetzt hätte ich dir fast empfohlen die überflüssigen Zeichen mit Suchen / Ersetzen im Menü Bearbeiten zu entfernen. Das geht zwar, aber vorsichtig mit den Sternchen. Die kannst du nur loswerden, wenn du eine Tilde (~) davor setzt. Sonst ist die Zelle leer. Die Leerzeichen kannst du dann auf die gleiche Weise, ohne Tilde, entfernen.
Dann wandelst du die Inhalte mit dieser Formel: =WENN(LÄNGE(B2)=9;LINKS(B2;5)&"-"&RECHTS(B2;4);B2) entsprechend deiner Wünsche um. Anschließen Spalte kopieren / Inhalte einfügen / Werte, (um die Formeln wieder los zu werden). Das war es dann.



Viele Grüße Klaus-Dieter

Klaus-Dieter's Excel und VBA Seite
Online-Excel



  

Betrifft: oder so ... von: Matthias L
Geschrieben am: 06.01.2010 15:15:01

Hallo

in C2

=WECHSELN(WENN(LÄNGE(B2)=8;B2;WENN(LÄNGE(B2)>8;GLÄTTEN(WECHSELN(B2;"*";""));""));" ";"")

und runterkopieren

Gruß Matthias


  

Betrifft: AW: Art.nr. formatieren von: Tim
Geschrieben am: 06.01.2010 15:18:33

Hallo Leute,

wow ihr seid ja verrueckt ;-)

ich habe alle Vorschlaege getestet, und alle funktionieren.
Habe mich am Ende fuer Matthias L's Variante entschieden!!

Vielen lieben Dank euch allen!!!!

Gruesse,
Tim


  

Betrifft: AW: Art.nr. formatieren von: Tim
Geschrieben am: 06.01.2010 15:26:23

Hallo,

ich bins nochmal ;-)

die Loesung ist nahezu perfekt, sodass ich sie bereits auf die 30.000 Nummern angewandt habe.

Einige beginnen mit der ersten Ziffer 0. Gibt es eine Moeglichkeit, jeweils in allen Zellen die erste Ziffer zu loeschen, sofern sie mit 0 beginnt?

D.h. aus 010967601 wuerde 10967601 werden!

Vielen Dank nochmal!!!

Liebe Gruesse,

Tim


  

Betrifft: probier mal ... von: Matthias L
Geschrieben am: 06.01.2010 15:49:20

Hallo

https://www.herber.de/bbs/user/67015.xls

Gruß Matthias


  

Betrifft: AW: probier mal ... von: Tim
Geschrieben am: 06.01.2010 15:54:16

Hallo Matthias,

perfekt, so sollte das aussehen!!

Vielen Dank fuer deine Hilfe, hast mir echt eingies an Arbeit erleichter!!! ;)

Gruesse,

Timmy


Beiträge aus den Excel-Beispielen zum Thema "Art.nr. formatieren"