Microsoft Excel

Herbers Excel/VBA-Archiv

Benötige Hilfe bei Auswertung | Herbers Excel-Forum


Betrifft: Benötige Hilfe bei Auswertung von: Marcel
Geschrieben am: 07.01.2010 09:49:08

Hallo zusammen,

ich benötige Hilfe bei folgendem Problem:

Ich habe eine Liste in der auf einem Arbeitsplatz Kundenreklamationen eingetragen werden...

sieht in etwa so aus:

Monat Grund
1 Grund1
1 Grund4
2 Grund2
3 Grund1
....usw.

Nun habe ich ein 2. Arbeitsblatt das wie folgt aussieht:

1 2 3 4 5 6 7 8 9 10 11 12
Grund1
Grund2
Grund3
Grund4

Ich hätte nun gerne auf diesem Arbeitsblatt einen Button, der mir mit Klick darauf eine Auswertung startet und vom 1. Arbeitsblatt zb. Monat 1 alle Gründe zählt und die Summe jeweils dem Grund zugeordnet aufs 2. Arbeitsblatt schreibt...

Ich müsste eigentlich nur wissen, wie der Code für die Auswertung aussehen sollte, ins 2. Arbeitsblatt schreiben schaffe ich selber :-)

Programmiere leider nur wenn ich mal programmieren muss im Access VBA und das ist dann vom Code her doch ein wenig unterschiedlich ;-)

Danke,

Beste Grüße

Marcel

  

Betrifft: AW: Benötige Hilfe bei Auswertung von: Josef Ehrensberger
Geschrieben am: 07.01.2010 09:55:17

Hallo Marcel,

warum VBA?

Tabelle1

 ABCDEFGHIJK
1MonatGrund    12345
21Grund 1   Grund 110000
31Grund 2   Grund 221000
41Grund 2   Grund 301000
52Grund 3   Grund 402000
62Grund 4         
72Grund 2         
82Grund 4         

Formeln der Tabelle
ZelleFormel
G2=SUMMENPRODUKT(($B$2:$B$100=$F2)*($A$2:$A$100=G$1))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: Benötige Hilfe bei Auswertung von: Marcel
Geschrieben am: 07.01.2010 09:59:04

Hallo Sepp,

danke für die schnelle Antwort!

Ich habe aber das Problem, dass ich ein Arbeitsblatt namens "Reklamationen" und eine namens "Auswertung" habe...

Wie würde der Befehl dann aussehen bzw. ist das dann überhaupt möglich?

Gruss Marcel


  

Betrifft: AW: Benötige Hilfe bei Auswertung von: Josef Ehrensberger
Geschrieben am: 07.01.2010 10:09:36

Hallo Marcel,

sicher ist das möglich, solltest du bei "Excel gut" aber wissen.

Auswertung

 ABCDEF
1 12345
2Grund 110000
3Grund 221000
4Grund 301000
5Grund 402000

Formeln der Tabelle
ZelleFormel
B2=SUMMENPRODUKT((Reklamation!$B$2:$B$100=$A2)*(Reklamation!$A$2:$A$100=B$1))


Reklamation

 AB
1MonatGrund
21Grund 1
31Grund 2
41Grund 2
52Grund 3
62Grund 4
72Grund 2
82Grund 4


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: Benötige Hilfe bei Auswertung von: Marcel
Geschrieben am: 07.01.2010 10:28:15

Wenn dann sollte es aber so aussehen, oder?

=SUMMENPRODUKT((Reklamation!$B$2:$B$100=$A2)*(Auswertung!$A$2:$A$100=B$1))

Gruss Marcel


  

Betrifft: Nein! warum den auch? o.T. von: Josef Ehrensberger
Geschrieben am: 07.01.2010 10:39:22

Gruß Sepp



  

Betrifft: AW: Benötige Hilfe bei Auswertung von: Marcel
Geschrieben am: 07.01.2010 10:51:15

Hmmm.... also irgendwas passt bei mir nicht...

Ich bekomme immer das Ergebnis 982 .....

Das Problem ist, dass ich die Formel nich ganz checke und deshalb die Fehlersuche nicht ganz so leicht ist :-)

Ich schau mir das ganze am Besten nochmal an...

Gruss Marcel


  

Betrifft: AW: Benötige Hilfe bei Auswertung von: Josef Ehrensberger
Geschrieben am: 07.01.2010 10:52:19

Hallo Marcel,

dann lade doch ein Beispiel hoch, in dem es nicht funktioniert.


Gruß Sepp



  

Betrifft: AW: Benötige Hilfe bei Auswertung von: Marcel
Geschrieben am: 07.01.2010 10:59:37

Hallo Sepp,

Hier der Link:

https://www.herber.de/bbs/user/67031.xls

Danke für deine Hilfe!

Gruss Marcel


  

Betrifft: AW: Benötige Hilfe bei Auswertung von: Josef Ehrensberger
Geschrieben am: 07.01.2010 11:05:29

Hallo Marcel,

du musst natürlich schon die richtigen Zellverweise setzen!

Warum2010

 BCDEFGHIJKLMNO
7 123456789101112 
8Analysewerte nicht ok100000000000 
9Auszeichnungfehler000000000000 
10Farbe000000000000 
11Fremdkörper000000000000 
12Geschmack / Geruch000000000000 
13Konsistenz000000000000 
14Lochung000000000000 
15Mikrobio000000000000 
16Temperaturabweichung100000000000 
17Textur000000000000 
18Verpackung100000000000 
19Sonstiges000000000000 
20Gesamt:300000000000 
21              

Formeln der Tabelle
ZelleFormel
C8=SUMMENPRODUKT((Reklamationen2010RWPH!$K$16:$K$1000=$B8)*(Reklamationen2010RWPH!$A$16:$A$1000=C$7))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: Benötige Hilfe bei Auswertung von: Marcel
Geschrieben am: 07.01.2010 11:06:38

Hatte eigentlich gedacht dass ich das gemacht habe :-)

Besten Dank!

Gruss Marcel


Beiträge aus den Excel-Beispielen zum Thema "Benötige Hilfe bei Auswertung"