Microsoft Excel

Herbers Excel/VBA-Archiv

Formle anpassung | Herbers Excel-Forum


Betrifft: Formle anpassung von: Nibio
Geschrieben am: 17.01.2010 14:01:07

Hallo Profis,

ich würde oft geholfen hier in diesen Forum, dafür möchte ich mich bei allen ganz herzlich bedanken,
Ihr seit einfach spitze.

Ich habe leider noch ein Problem, würde mich freunen wenn jemand eine Lösung hätte.
Ich habe in Zelle E15 die zahl "4001", und die Formel unten schaut ob der erste Zahl eine "4" oder eine "3" ist und gibt 149 oder 139 je dach dem. Funktioniert gut, doch leider passiert oft dass der Zahl mit eine oder mehreren leeren Zeichen anfangen,
wie z.B " 4001" oder "  4001" usw.... Dann funktioniert die Formel nicht mehr (weil der erste Zeichen eine leere Stelle ist), hätte vielleicht jemand eine Lösung dafür?

=WENN(TEIL(E15;1;1)="3";139;WENN(TEIL(E15;1;1)="4";149;""))

Vielen Dank im voraus,
Nibio

  

Betrifft: AW: Leerzeichen VOR der Zahl von: dieter(drummer)
Geschrieben am: 17.01.2010 14:12:39

Hi Nibio,

wenn Leerzeichen VOR der Zahl in E15 sind, hat das KEINE Auswirkung auf deine Formel. Gib mal Leerzeichen vor der Zahl ein, dann prüfe die Zelle. Du wirst sehen, dass die Leerzeichen NICHT vorhanden sind und die Zahl als Zahl da ist. Nur wenn eine Leerzelle innerhalb der Zahl ist, wird diese links in der Zelle angezeigt und selbts dann funktioniert die Formel noch.

Gruß, Dieter(Drummer)


  

Betrifft: AW: Leerzeichen VOR der Zahl von: Nibio
Geschrieben am: 18.01.2010 10:57:40

Danke an allen,

Gruß
Nibio


  

Betrifft: AW: Formle anpassung von: Josef Ehrensberger
Geschrieben am: 17.01.2010 14:16:57

Hallo Nibio,

=WENN(LINKS(GLÄTTEN(E15);1)="3";139;WENN(LINKS(GLÄTTEN(E15);1)="4";149;""))
Gruß Sepp



  

Betrifft: AW: Formle anpassung von: Nibio
Geschrieben am: 18.01.2010 10:53:41

Herzlichen Dank,

das funktioniert bei mir super!

Gruß
Nibio


  

Betrifft: AW: Formle anpassung von: hary
Geschrieben am: 17.01.2010 14:23:53

Hallo Nibio
so?
=WENN(TEIL(A1*1;1;1)="3";139;WENN(TEIL(A1*1;1;1)="4";149;""))
gruss hary
@ Dieter: Die zahl ist keine Zahl sondern Text. Sonst ginge es nicht mit den Leerzeichen.


  

Betrifft: A1 aendern in E15 owT. von: hary
Geschrieben am: 17.01.2010 14:27:33

.


  

Betrifft: AW: @Hary - Bei mir gehts von: dieter(drummer)
Geschrieben am: 17.01.2010 14:38:38

Hi Hary,

Du hast natürlich Recht, dass es dann Text ist, wenn ich in (hier) E15 z.B. 4 001 eingebe, _ funktioniert die Formel

=WENN(TEIL(E15;1;1)="3";139;WENN(TEIL(E15;1;1)="4";149;"")) 
trotzdem. In der Formelzelle wird bei mir dann das Ergebnis 149 als Zahl angezeigt.

Gruß, Dieter(Drummer)


  

Betrifft: AW: @Hary - Bei mir gehts von: hary
Geschrieben am: 17.01.2010 14:48:47

hallo Dieter
richtig, ist ja auch Text.
mach aber mal ein leerzeichen vorne vor.

Tabelle1

 AB
1 4001 
24 001149

verwendete Formeln
Zelle Formel
B1 =WENN(TEIL(A1;1;1)="3";139;WENN(TEIL(A1;1;1)="4";149;""))
B2 =WENN(TEIL(A2;1;1)="3";139;WENN(TEIL(A2;1;1)="4";149;""))

Zahlenformate
Zelle Format Wert
A1 @ 4001
A2 @4 001
Zellen mit Format Standard werden nicht dargestellt

Tabellendarstellung in Foren


gruss hary


  

Betrifft: AW: Ok ... von: dieter(drummer)
Geschrieben am: 17.01.2010 15:01:10

Hary,

mit Leerzeichen vor der Zahl = Leer4Leer001 zeigt die Formelzelle micht und deshalb die Multiplikation mit 1.

Am Anfang war wohl kein Hinweis, dass innerhalb der Zahl ein Leerzeichen ist und dann Leerzeichen vor der Zahl.

Hab wieder was gelernt.

Gruß, Dieter(Drummer)


  

Betrifft: AW: nee, aber.. von: hary
Geschrieben am: 17.01.2010 15:18:14

Hallo Dieter
....Zitat: z.B " 4001" oder " 4001" usw.
vor der zahl sind ein bzw. zwei Leerzeichen.
gruss hary


  

Betrifft: AW: Egal wieviel Leerzeichen VOR ... von: dieter(drummer)
Geschrieben am: 17.01.2010 15:37:58

... der Zahl sind, wenn keine Leerzeichen innerhalb der Zahl sind, bleibt es bei mir eine Zahl. Bei z.B. 6 Leerzeichen VOR der Zahl und dann mit Enter bestätigt. Dann wird in der Zelle NUR die Zahl OHNE Leerzeichen gezeigt und belibt eine Zahl und entsprechend funktioniert die Formel.

Angabe lt. ... Zitat war: " 4001" oder " 4001". Evtl. steh ich ja irgendwo auf dem Schlauch. Ich möchte wohl die Sache nicht ins Unendliche führe. Danke Hary!

Gruß, Dieter(Drummer)


  

Betrifft: AW: aber nur wenn... von: Daniel
Geschrieben am: 17.01.2010 17:00:19

... die Daten von Hand eingegeben wurden und das eingabefeld nicht "Text" als Zahlenformat hat.

bei Importierten Daten oder Zahlenformat "Text" sind Leerzeichen vor einer "Zahl" durchaus möglich.

Gruß, Daniel


  

Betrifft: AW: Danke Daniel für Info ... von: dieter(drummer)
Geschrieben am: 17.01.2010 17:14:30

... hab nicht an Importdaten gedacht. Dies ist dann ja auch natürlich möglich, dass es Text ist und die Multiplikation erforderlich macht um eine Zahl zu erhalten.

Danke und Gruß
Dieter(Drummer)


  

Betrifft: AW: aber nur wenn... von: Nibio
Geschrieben am: 18.01.2010 11:03:02

ja das stimmt, Vielen Dank an Euch allen!

Gruß
Nibio


  

Betrifft: AW: Egal wieviel Leerzeichen VOR ... von: Nibio
Geschrieben am: 18.01.2010 11:01:52

... nein stimmt nicht so ganz, bei mir werden 6 Leerzeichen auch angezeigt (Excel 2003).

Gruß
Nibio


  

Betrifft: AW: Formle anpassung von: Nibio
Geschrieben am: 18.01.2010 10:56:49

Hallo Hary,

danke, funktioniert auch, es gibt aber Probleme wenn en leere Zeichen an der zweite stelle vorkommt,
was aber nicht der Fall sein wird.

Danke Vielemals!

Gruß
Nibio


Beiträge aus den Excel-Beispielen zum Thema "Formle anpassung"