Microsoft Excel

Herbers Excel/VBA-Archiv

Zelle hochzählen | Herbers Excel-Forum


Betrifft: Zelle hochzählen von: Karlheinz
Geschrieben am: 29.01.2010 06:41:33

Hallo alle zusammen .....

Komme nicht auf eine Formel bzw. finde nichts wo ich nach suchen könnte !

Problem: Möchte eine Formel zusammenstellen in der folgendes berechnet werden kann.....

A B C D
1 X 10 =wenn(A1="X";A1+10;"") ( nur so zum Beispiel )
2
3 X 10
4 X 10

Stelle mir das so vor wenn in A1 ein "X" steht dann soll in zb. D1 eine berechnung erfolgen.
Steht zb. in A2 kein "X" dann soll in der Formel die berechnungsgrundlage der nächsten Zeile genommen werden aber der Wert falls in A2 kein "X" steht soll dann in D2 dargestellt werden.
Möchte damit erreichen das die "neue" Liste Tabelle keine Leerzeilen aufweist....

Gruss Karlheinz

  

Betrifft: AW: Zelle hochzählen von: Hajo_Zi
Geschrieben am: 29.01.2010 08:08:05

Hallo Karl Heinz,

ich verstehe Dein Problem nicht. Trage die Formel in D1 ein und ziehe Sie runter.
Ansonsten stelle Deine Tabelle hier im Forum da, vielleicht in Spalte E was da stehen soll. Oder lade die Datei hoch.

GrußformelHomepage


  

Betrifft: AW: Zelle hochzählen von: Karlheinz
Geschrieben am: 29.01.2010 08:16:31

Hallo Hajo,

ich meine das eine Zeile übersprungen werden könnte ... hoffe Du kommst mit dem Beispiel weiter ....

Gruss Karlheinz

https://www.herber.de/bbs/user/67607.xls


  

Betrifft: AW: Zelle hochzählen von: Hajo_Zi
Geschrieben am: 29.01.2010 08:23:10

Halo Karlheinz,

das ist mir immer noch nicht klarer. Wird die Formel in B4 eingetragen ist es ein Zirkelbezg.

Tabelle1

 ABCDE
4+TEST 1Test 1  TEST 1
5  TEST 2Test 2   
6+TEST 3Test 3  TEST 3
7+TEST 4Test 4  TEST 4
8  TEST 5Test 5   
9  TEST 6Test 6   
10+TEST 7Test 7  TEST 7
11+TEST 8Test 8  TEST 8
12+TEST 9Test 9  TEST 9
13+TEST 10Test 10  TEST 10

verwendete Formeln
Zelle Formel
C4 ="Test 1"
E4 =WENN(A4="+";B4;"")
C5 =LINKS(C4;5)&ANZAHL2($C$4:C4)+1
E5 =WENN(A5="+";B5;"")
C6 =LINKS(C5;5)&ANZAHL2($C$4:C5)+1
E6 =WENN(A6="+";B6;"")
C7 =LINKS(C6;5)&ANZAHL2($C$4:C6)+1
E7 =WENN(A7="+";B7;"")
C8 =LINKS(C7;5)&ANZAHL2($C$4:C7)+1
E8 =WENN(A8="+";B8;"")
C9 =LINKS(C8;5)&ANZAHL2($C$4:C8)+1
E9 =WENN(A9="+";B9;"")
C10 =LINKS(C9;5)&ANZAHL2($C$4:C9)+1
E10 =WENN(A10="+";B10;"")
C11 =LINKS(C10;5)&ANZAHL2($C$4:C10)+1
E11 =WENN(A11="+";B11;"")
C12 =LINKS(C11;5)&ANZAHL2($C$4:C11)+1
E12 =WENN(A12="+";B12;"")
C13 =LINKS(C12;5)&ANZAHL2($C$4:C12)+1
E13 =WENN(A13="+";B13;"")

Tabellendarstellung in Foren Version 5.5


Du könntest auch einfach in die erste Zelle "Test 1" schreiben und runterziehen.

Gruß Hajo


  

Betrifft: AW: Zelle hochzählen von: Karlheinz
Geschrieben am: 29.01.2010 08:43:08

Hallo Hajo !

vom Ansatz her ist das so wie ich das jetzt auch habe nur wollte ich die Zeile überspringen wenn der Wert in der Zelle nicht gegeben ist sollte dann der Wert der nächsten Zelle genommen werden wo
der Wert das besagt "X" in der Zelle stehen hat ... weiss nicht wie ich mich da anders ausdrücken soll !!

Daher nochmal vielen Dank für die Hilfe !

In E5 soll dann der Wert aus B6 stehen da ja kein in Zelle A5 kein "X" steht...


vielleicht ja auch nicht möglich nur in Excel wahrscheinlich eher was mit VBA

Gruss Karlheinz


  

Betrifft: AW: Zelle hochzählen von: Hajo_Zi
Geschrieben am: 29.01.2010 08:56:08

Hallo Karlheinz,

n Deiner Vorgabe steht Test 1; Test 2 usw. Deine Beschrebung könnnte man vielleicht auch anders interpretieren. Ich hatte ja geschrieben schreibe hib was Du haben möchtest und Du hast es so hingeschrieben wie oben beschrieben. Die Lösung habe ich umgesetzt. Vielleicht ist Deiune Beschreibung in der Datei falsch?

Gruß Hajo


Beiträge aus den Excel-Beispielen zum Thema "Zelle hochzählen"