Microsoft Excel

Herbers Excel/VBA-Archiv

Hintergrund Farbe Summe Addieren | Herbers Excel-Forum


Betrifft: Hintergrund Farbe Summe Addieren von: Zettler Fritz
Geschrieben am: 31.01.2010 11:47:38

Hallo zusammen
Wer kann mir helfen In Excel bzw. VBA
ich möchte Zellen Werte Addieren die per Bedingter Formatierung Farblich hinterlegt wurden,
Schriftfarbe dann Weiß ( mehrere Spalten ) deren Zellen werte Addieren.

z.b. A1:A100 0 Roter Hintergrund per Bedingter Formtierung SUMME Addieren und in Zelle A111 eintragen

Vielen Dank im voraus !!!

  

Betrifft: mit SUMMENPRODUKT... von: Tino
Geschrieben am: 31.01.2010 11:54:20

Hallo,
Beispiel:

=SUMMENPRODUKT((A1:A110=0)*B1:E110)

Gruß Tino


  

Betrifft: mit VBA z. Bsp. so... von: Tino
Geschrieben am: 31.01.2010 12:58:11

Hallo,
mit VBA kannst Du die Summe aus dem Bereich z. Bsp. so ermitteln.

Dim rngRange As Range
Dim SuchWert As String

SuchWert = "0"
Set rngRange = Tabelle1.Range("A1:E110")

Tabelle1.Range("A111") = _
Evaluate("=SUMPRODUCT((" & _
        rngRange.Columns(1).Address(External:=True) & "=" & SuchWert & ")*" & _
        rngRange.Columns("B:E").Address(External:=True) & ")")


Gruß Tino


  

Betrifft: AW: Hintergrund Farbe Summe Addieren von: Hajo_Zi
Geschrieben am: 31.01.2010 12:02:27

Hallo Fritz,

das ist sehr kompliziert in VBA. Bilde die Summe nach der Bedingung für die Farbe.

GrußformelHomepage


Beiträge aus den Excel-Beispielen zum Thema "Hintergrund Farbe Summe Addieren"