Microsoft Excel

Herbers Excel/VBA-Archiv

Häufigster Begriff | Herbers Excel-Forum


Betrifft: Häufigster Begriff von: Anja
Geschrieben am: 04.02.2010 11:32:49

Hallo,

ich habe folgende Formel, die mir die Anzahl von Vorgängen errechnet, welche innerhalb der gewünschten Kalenderwochen erfolgt sind.

=SUMMENPRODUKT((A5:A1000>=D1)*(A5:A1000<=D2)*B5:B1000)

Nun möchte ich diese aber erweitern, und zwar, sollen nur die Vorgänge gezählt werden, in dessen Zelle "JA" bzw. andere bestimmte Wörter stehen.

Und nun benötige ich noch eine Formel welche mir ausgibt, welcher Begriff/Satz (KEINE Zahl!) am häufigsten innerhalb einer Spalte (z.B. H5:H1000) vorkommt, mit Ausnahme von "K/A"

Diese ebenfalls unter Berücksichtigung der oben erwähnten Formel mit den Kalenderwochen.

Vielen - VIELEN - Dank für Eure Hilfe :)

  

Betrifft: AW: Häufigster Begriff von: Ramses
Geschrieben am: 04.02.2010 11:41:21

Hallo

"...in dessen Zelle "JA" bzw. andere bestimmte Wörter stehen...."

In WELCHER Zelle/Spalte ?

Gruss Rainer


  

Betrifft: AW: Häufigster Begriff von: Anja
Geschrieben am: 04.02.2010 11:46:11

Die Zellen H5:H1000 sollen überprüft werden :)


  

Betrifft: AW: Häufigster Begriff von: Ramses
Geschrieben am: 04.02.2010 11:51:04

Hallo

Tabelle2

 ABCDEFGH
1Ergebnis2 01.01.2010    
2   31.01.2010    
3   Ja    
4        
501.01.20101     Ja
605.01.20101      
731.01.20101     Ja
801.03.20101      
9        
10        

Formeln der Tabelle
ZelleFormel
B1=SUMMENPRODUKT((A5:A8>=D1)*(A5:A8<=D2)*(H5:H8=D3)*B5:B8)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



Gruss Rainer


  

Betrifft: AW: Häufigster Begriff von: Anja
Geschrieben am: 04.02.2010 12:34:00

Wow, Dankeschön!

Das ging schnell :)

Allerdings benötige ich noch die Formel, die mir den häufigsten Begriff anzeigen soll separat.

Zur Situation:

In der Spalte G5:ganz-weit-unten habe ich ein Dropdownmenü erstellt, womit sich immer wiederkehrende Begriffe auswählen lassen. Z.b.: Grün, Blau, Rot. Der Begriff, welcher am häufigsten vorkommt, soll dann ausgegeben werden; also nicht bloss ein fester Begrifft, wie "JA" der sich schon in einer Zelle befindet (wie in der Beispieltabelle oben D3)

Und hier sollen wiedermal die gewünschten Kalenderwochen beachtet werden. Heißt; Am besten in vorhandene untenstehende Formel verschachteln:

=SUMMENPRODUKT((A5:A1000>=D1)*(A5:A1000<=D2)*B5:B1000)


  

Betrifft: Sorry,... keine Lösung. von: Ramses
Geschrieben am: 04.02.2010 12:43:29

Hallo

Den häufigsten Eintrag in einer Spalte ist kein problem, nur die Abhängigkeit von Datumsgrenzen macht mir Probleme.
Daher die Frage noch auf offen.

Gruss Rainer


  

Betrifft: Du solltest die Antworten in den anderen Foren.... von: Ramses
Geschrieben am: 04.02.2010 14:39:10

Hallo

... auch mal nachsehen

http://www.online-excel.de/fom/fo_read.php?f=1&bzh=47214&h=47201&ao=1#a123x

Dort steht die Lösung für dein zweites problem

Gruss Rainer


Beiträge aus den Excel-Beispielen zum Thema "Häufigster Begriff"