Problem bei einer Zeitabfrage

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
MsgBox


Excel-Version: 10.0 (Office XP)
nach unten

Betrifft: Problem bei einer Zeitabfrage
von: Thorsten K.
Geschrieben am: 24.05.2002 - 14:26:24

Ich nutze eine Excelformel in dem Stil:

In Zelle B1 steht
=WENN(A1=1;JETZT();"")

Dann möchte ich in einem Makro die Zeit prüfen:
IF TIME > RANGE("B1") THEN
...
END IF

Obwohl die Zeit in B1 14:03:24 ist und die aktuelle Zeit später, funktioniert die Abfrage nicht.
Wenn ich als Überwachung im Debugmodus Range("B1") eingebe, steht auch nciht die richtige Uhrzeit, sondern 37400,5858703704

Wie kann ich die Abfrage ändern, dass es klappt ?

Danke Euch !!

nach oben   nach unten

Re: Problem bei einer Zeitabfrage
von: Rolf, Lgh.
Geschrieben am: 24.05.2002 - 14:35:35

Hallo Thorsten,
versuch es mal so:
IF TIME > CDate(RANGE("B1")) THEN
Gruss Rolf
nach oben   nach unten

Klappt leider nicht!
von: Thorsten K.
Geschrieben am: 24.05.2002 - 14:37:54

Nach der IF-Prüfung geht Excel wieder direkt zum End If...

nach oben   nach unten

Re: Klappt leider nicht!
von: MRR
Geschrieben am: 24.05.2002 - 15:06:40

Hast Du es mal mit TimeValue(Range("B1")) versucht?
Matthias

nach oben   nach unten

Re: Klappt leider nicht!
von: Rolf, Lgh.
Geschrieben am: 24.05.2002 - 15:22:59

Die 1. MsgBox wird bei mir angezeigt:

Sub text()
  TestZeit = Range("B1")
  If Time CDate(TestZeit) Then
    MsgBox "1.: " & CDate(TestZeit)
  ElseIf Time > TestZeit Then
    MsgBox "2.: " & TestZeit
  End If
End Sub

Gruss Rolf
nach oben   nach unten

Besser so:
von: MRR
Geschrieben am: 24.05.2002 - 15:33:22

If Time > TimeValue(Format(Range("B1"), "hh:mm:ss")) Then
Matthias
nach oben   nach unten

Re: Besser so:
von: Rolf, Lgh.
Geschrieben am: 24.05.2002 - 15:39:40

Hallo Matthias,
Deine Lösung geht bei mir nicht:

Sub text()
  TestZeit = Range("B1")
  If Time CDate(TestZeit) Then
    MsgBox "1.: " & CDate(TestZeit)
  ElseIf Time TimeValue(Format(Range("B1"), "hh:mm:ss")) Then
    MsgBox "2.: " & TestZeit
  End If
End Sub

Gruss Rolf
nach oben   nach unten

Re: Besser so:
von: MRR
Geschrieben am: 24.05.2002 - 15:59:57


Sub text()
  TestZeit = TimeValue(Format(Range("B1"), "hh:mm:ss"))
  If Time > TestZeit Then
    MsgBox "1.: " & TestZeit
  End If
End Sub

Matthias
 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Problem bei einer Zeitabfrage"