Microsoft Excel

Herbers Excel/VBA-Archiv

SVerweis | Herbers Excel-Forum


Betrifft: SVerweis von: ottgunter
Geschrieben am: 04.01.2012 13:03:11

Hallo

Habe am 1.1 mein Problem ins Forum gestellt. Bekam auch die Lösung.
Die Sache hat doch noch einen Hacken. Wenn ich im Medikamentenblatt eine Änderung durchführe,
wird dieses nicht im Bestellungsblatt übernommen. Die Felder PZN und Inhalt bleiben dann leer.


https://www.herber.de/bbs/user/78205.xlsx

Gruß Gunter

  

Betrifft: AW: SVerweis von: ottgunter
Geschrieben am: 04.01.2012 15:37:11

Hallo
Vieleicht kann mann hier das Problem erkennen, warum die PZN und Inhaltspalte nicht
ausgefüllt werden, wenn ich in dem Medikamentenblatt änderungen gemacht habe


Bestellungsblatt

Bestellung

 ABCDEF
22Xylocitin 1%006799010x10ml1 4 DMAP

Formeln der Tabelle
ZelleFormel
B22=WENN(ISTFEHLER(SVERWEIS($A22;'[Medikamente]Medikamente '!$A$6:$C$72;SPALTE(); 0)); "";SVERWEIS($A22;'[Medikamente]Medikamente '!$A$6:$C$72;SPALTE(); 0))
C22=WENN(ISTFEHLER(SVERWEIS($A22;'[Medikamente]Medikamente '!$A$6:$C$72;SPALTE(); 0)); "";SVERWEIS($A22;'[Medikamente]Medikamente '!$A$6:$C$72;SPALTE(); 0))
F22='Medikamente '!A6


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Medikamentenblatt
Medikamente

 ABC
64 DMAP20576075x5ml


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



Gruß gunter


  

Betrifft: AW: SVerweis von: Matthias
Geschrieben am: 04.01.2012 16:56:12

Hallo Gunter,

welche Änderungen machst du denn im "Medikamenten" Blatt.

Wer soll das erraten ?

Gruß Matthias


  

Betrifft: AW: SVerweis von: ottgunter
Geschrieben am: 04.01.2012 17:02:34

Hallo Matthias

Es findet ja mal eine Änderung im Lager statt. Eins fällt weg, ein neues kommt.

Gruß Gunter


  

Betrifft: AW: SVerweis von: Matthias
Geschrieben am: 04.01.2012 17:05:10

Hallo gunter,

du ÄNDERST was?

Genau: gunter änder die "LISTE"...und wo hast du die defeniert ?

Matthias

Ps.: bissel grübeln musst du auch mal.....Kleiner Tipp "Datengültigkeit"


  

Betrifft: AW: SVerweis von: ottgunter
Geschrieben am: 04.01.2012 17:41:54

Hallo Matthias

Im Blatt Medikamente kann es ja zum Austausch einiger Medikamente kommen.
Also muß ich dieses dann auch in dieser Aufstellung ändern.z.B. 4DMAP gibt es ab
morgen nicht mehr. Dafür aber 3DMAP. Ich trage also ein neuen
Handelsname ein, eine neue bestell Nr. und die Verpackungsmenge.
Wenn ich dann im Blatt Bestellung dieses neue Medikament eintrage, dann erscheint
keine Bestellnummer und Verpackungmenge.Und dieses Problem kann ich nicht lösen.

Gruß Gunter


  

Betrifft: AW: SVerweis von: Matthias
Geschrieben am: 04.01.2012 17:47:14

Gunther ,

check mal diese Datei ab,

Den Bereich der Medikamente kannst du nun bis Zeile A150 erweitern.
die Abfrage sollte auch gehen.

https://www.herber.de/bbs/user/78213.xlsx

So OK ???

Matthias


  

Betrifft: AW: SVerweis von: ottgunter
Geschrieben am: 04.01.2012 18:13:55

Danke Matthias

Jetzt ist alles ok.

Gruß Gunter


Beiträge aus den Excel-Beispielen zum Thema "SVerweis"