Microsoft Excel

Herbers Excel/VBA-Archiv

Felder zählen | Herbers Excel-Forum


Betrifft: Felder zählen von: Günter Bieler
Geschrieben am: 11.01.2012 19:21:17

Hallo,
ich habe mit Exel einen Stundenplan für eine Schule gemacht.
So sieht er aus:
http://img811.imageshack.us/img811/1802/stuplaexelfrage.jpg

Ich würde gerne in den farbigen Feldern in der untersten Reihe die Anzahl der gleichfarbigen Felder im ganzen Plan (oder auch der entsprechenden Namenskürzel) zählen lassen. Geht sowas?
Kann man das auch für "noobs" erklären?
Danke schon mal für evtl. Hilfen :-))

  

Betrifft: =ZÄHLENWENN(A1:AZ100;"Bei") _oT von: NoNet
Geschrieben am: 11.01.2012 19:29:03

_oT = "ohne Text"


  

Betrifft: AW: =ZÄHLENWENN(A1:AZ100;"Bei") _oT von: Günter Bieler
Geschrieben am: 11.01.2012 20:13:00

Danke für die schnelle Antwort.
Ich habe mich an dem ersten unteren Feld versucht, der blauen 17,
hab also eingegeben:
=ZÄHLENWENN(A1:AZ100;"Kru") _oT
Darauf habe ich die folgende Fehlermeldung erhalten:
http://img818.imageshack.us/img818/327/fehlerah.jpg

Ich hab's auch ohne das _oT versucht, dann krieg ich den Hinweis auf einen Zirkelbezug (auf Feld AT45)


  

Betrifft: AW: =ZÄHLENWENN(A1:AZ100;"Bei") _oT von: Uwe (:o)
Geschrieben am: 11.01.2012 20:47:18

Hallo Günter,
ich habe jetzt das Problem nicht näher betrachtet, aber die Formel, die NoNet vorschlägt lautet nur:
=ZÄHLENWENN(A1:AZ100;"Bei")
das _oT heißt nur ohne Text, und deutet darauf hin, dass kein weiterer Text folgt.
Also lasse einfach mal das _oT weg.
Und wenn der Thread noch offen ist, klick das "Frag noch offen" -Feld an, sonst schaut keiner mehr 'rein.

Gruß
Uwe
(:o)


  

Betrifft: AW: =ZÄHLENWENN(A1:AZ100;"Bei") _oT von: Martin
Geschrieben am: 11.01.2012 20:50:01

Hallo Günter,

lass mal das _oT weg (ohne Text halt) und dann sorge dafür, dass dein Zählfeld außerhalb der Suchmatrix (A1:AZ100) liegt (z.B. A1:AZ44) dann sollte es funktionieren.

Gruß

Martin


  

Betrifft: AW: Felder zählen von: Günter Bieler
Geschrieben am: 11.01.2012 21:13:05

super!
Vielen Dank an alle, besonders Martin;
"außerhalb der Suchmatrix" war die Lösung :-))


Beiträge aus den Excel-Beispielen zum Thema "Felder zählen"