Microsoft Excel

Herbers Excel/VBA-Archiv

Doppeleintrag verhindern | Herbers Excel-Forum


Betrifft: Doppeleintrag verhindern von: Rosi
Geschrieben am: 19.01.2012 13:43:21

Hallo Forum,

wenn ich in einer (relativ großen) Tabelle eine Zahl eingebe (die es nur einmal geben darf),gibt es da die Möglichkeit dass ich sofort eine Meldung erhalte dass diese Zahl bereits eingegeben wurde??

Die Eingabe erfolgt immer in der gleichen Spalte,wird aber irgendwann in ein anderes Blatt -gleiche Spalte-kopiert (Archiv),so dass auch dort die Möglichkeit einer "Doppeleingabe" bestehen könnte.

Wäre für entsprechende Hinweise sehr dankbar.
Gruß Rosi

  

Betrifft: AW: Doppeleintrag verhindern von: Josef Ehrensberger
Geschrieben am: 19.01.2012 14:26:33


Hallo Rosi,

das kannst du über "Daten" > "Gültigkeit" > "Benutzerdefiniert" erreichen.

Z. B. für die Zelle A1

=ZÄHLENWENN($A:$A;A1)+ZÄHLENWENN(Archiv!$A:$A;A1)=1




« Gruß Sepp »



  

Betrifft: das geht so nicht von: Rudi Maintaire
Geschrieben am: 19.01.2012 14:56:31

Hallo,
in Gültigkeit sind Bezüge auf andere Tabellen nicht zulässig. Erst Namen für Archiv!A:A vergeben.
Weißt du doch sicher. ;-)

Gruß
Rudi


  

Betrifft: AW: das geht so nicht von: Josef Ehrensberger
Geschrieben am: 19.01.2012 15:06:47


Hallo Rudi,

geht schon, allerdings nicht bei der von Rosi angegebenen Version, die hab ich "überlesen";-))

Aber bei "Excel-gut" wird es daran wohl nicht scheitern


« Gruß Sepp »



  

Betrifft: geht ohne Namen von: WF
Geschrieben am: 19.01.2012 15:12:39

siehe:
http://www.excelformeln.de/tips.html?welcher=108

WF


  

Betrifft: ist mir bekannt ... von: Rudi Maintaire
Geschrieben am: 19.01.2012 16:00:14

Hallo,
nur vermeide ich INDIREKT wo immer es geht.
Wird 'Archiv' umbenannt, so bekommt INDIREKT das nicht mit. Ein Bereichsname hingegen schon.

Gruß
Rudi


  

Betrifft: AW: Doppeleintrag verhindern von: Rosi
Geschrieben am: 20.01.2012 08:48:26

Hallo und vielen Dank an alle,

habe mich für eine VBA-Lösung entschieden (um auf diesem Gebiet etwas aufzuholen).
Dateneingabe über UF und vor dem platzieren der Daten in der Tabelle die Abfrage in den beiden Spalten.
Funktioniert einwandfrei.
Trotzdem nochmals vielen Dank für eure Mühe

Gruß Rosi


  

Betrifft: AW: Doppeleintrag verhindern von: Rudi Maintaire
Geschrieben am: 19.01.2012 14:30:10

Hallo,
für die Originaltabelle per Gültigkeit.
A:A markieren, Daten-Gültigkeit-Benutzerdefiniert-Formel: =ZÄHLENWENN(A:A;A1)=1 und Meldung definieren.
Für die Kopie analog mit bedingter Formatierung (z.B. Rote Schrift, da Gültigkeit auf Copy&Paste nicht reagiert.

Gruß
Rudi


Beiträge aus den Excel-Beispielen zum Thema "Doppeleintrag verhindern"