Microsoft Excel

Herbers Excel/VBA-Archiv

Formel gesucht | Herbers Excel-Forum


Betrifft: Formel gesucht von: Jean Gitanes
Geschrieben am: 23.01.2012 13:26:37

Hallo,

ich suche eine kurze Formel für C10, die den Wert aus C1 erhalten soll, weil aktuell das Maximum in Spalte C liegt. Bisher ist mir dies nur mit mehreren Wenns gelungen.

Gruß
Jean

Tabelle1

 ABCDE
1DatumPersNr 1PersNr 2PersNr 3PersNr 4
215.02.20073585
316.02.200763710
417.02.200757107
518.02.2007612118
619.02.20078959
7         
8    12   
9         
10Gesuchte Formel       
11         
12PersNr 2       

verwendete Formeln
Zelle Formel Bereich
B8 =WENN(ZÄHLENWENN(B2:B6;MAX($B2:$E6)); MAX(B2:B6); "") 
C8 =WENN(ZÄHLENWENN(C2:C6;MAX($B2:$E6)); MAX(C2:C6); "") 
D8 =WENN(ZÄHLENWENN(D2:D6;MAX($B2:$E6)); MAX(D2:D6); "") 
E8 =WENN(ZÄHLENWENN(E2:E6;MAX($B2:$E6)); MAX(E2:E6); "") 

Tabellendarstellung in Foren Version 5.46


  

Betrifft: ich hab eine von: Rudi Maintaire
Geschrieben am: 23.01.2012 13:39:10

Hallo,

 ABCDE
1DatumPersNr 1PersNr 2PersNr 3PersNr 4
215.02.20073585
316.02.200763710
417.02.200757107
518.02.2007612118
619.02.20078959
7     
8     
9     
10Gesuchte Formel PersNr 2  

ZelleFormel
B8=WENN(ZÄHLENWENN(B2:B6;MAX($B$2:$E$6));MAX($B$2:$E$6);"")
C8=WENN(ZÄHLENWENN(C2:C6;MAX($B$2:$E$6));MAX($B$2:$E$6);"")
D8=WENN(ZÄHLENWENN(D2:D6;MAX($B$2:$E$6));MAX($B$2:$E$6);"")
E8=WENN(ZÄHLENWENN(E2:E6;MAX($B$2:$E$6));MAX($B$2:$E$6);"")
C10{=INDEX(B1:E1;VERGLEICH(WAHR;ISTZAHL(B8:E8);))}
Achtung, Matrixformel!
Die geschweiften Klammern{} nicht eingeben,
sondern die Zelle mit
Shift + Strg + Enter
verlassen statt Enter alleine.


Gruß
Rudi
rUDI


  

Betrifft: AW: Danke von: Jean Gitanes
Geschrieben am: 23.01.2012 15:12:48

Hallo Rudi,

vielen Dank für Deine Formel. Sie ist viel kürzer und funktioniert super.

Gruß
Jean


  

Betrifft: AW: Formel gesucht von: Andreas Emmert
Geschrieben am: 23.01.2012 13:40:54

Hi,

gib in C10 die Formel
=BEREICH.VERSCHIEBEN($A$1;0;SUMME(WENN(MAX($B$2:$E$6)=$B$2:$E$6;SPALTE($B$2:$E$6);0))-1;1;1)

ein und schließe mit Strg+Shift+Return ab (Arrayformel). Das löst dein Problem bei eindeutigen Maximum-werten, wenn es mehrere Werte geben sollte, die identisch mit dem Maximum sind, müsstest du eben noch eine WENN Abfrage dazuhängen.

viele Grüße
Andreas


  

Betrifft: AW: Danke und Zusatzfrage von: Jean Gitanes
Geschrieben am: 23.01.2012 15:39:37

Hallo Andreas,

vielen Dank für Deine Formel zu der ich noch eine Frage habe.
A5 ist Ausgangspunkt für die Ermittlung der Zelle, 0 gleiche Zeilc,
Wenn Summe bis Spalte -1 ergibt 2 nach rechts, also C5?
Wenn das richtig wäre, welchen Sinn hat dann die Angabe ;1;1?

Gruß
Jean


  

Betrifft: AW: Danke und Zusatzfrage von: Andreas Emmert
Geschrieben am: 24.01.2012 11:28:30

Hallo Jean,

richtig, die Angabe ;1;1 am Ende der Formel gibt nur an, dass der neue Bereich 1 Zeile hoch und 1 Spalte breit sein soll. Man könnte diese Parameter auch weglassen, dann käme das gleiche raus. mit Bereich.Verschieben könntest du aber bspw. auch ausgehend von einer bestimmten zelle einen Bereich aus mehreren Zellen generieren, so dass dann bspw. am Ende der Formel ;2;2 stehen würde (also 2 Zeilen hoch und 2 Spalten breit, den Bereich könnte man dann bspw. aufsummieren).

viele Grüße
Andreas


Beiträge aus den Excel-Beispielen zum Thema "Formel gesucht"