Microsoft Excel

Herbers Excel/VBA-Archiv

Suche nächste aktive Zelle | Herbers Excel-Forum


Betrifft: Suche nächste aktive Zelle von: GeHi
Geschrieben am: 23.01.2012 15:57:20

Hi,
ich habe eine Tabelle, in die unterschiedliche Ereignisse eingetragen werden. Dabei kommen hin und wieder in einer Spalte Werte vor, die ich auswerten möchte. Meine Formel nimmt den jüngeren Wert auf und soll sich den älteren Wert, der mehrere oder viele Zeilen weiter oben steht, zur Berechnung holen. Händisch geht so etwas mit -gehe zu-, wie kann ich das aber in die Formel (notfalls in ein Makro) einbauen.
Vielleicht kann mir jemand helfen? Viele Grüße GeHi - München, 25.01.2012

  

Betrifft: zeig doch mal ein Bsp. von: Matthias L
Geschrieben am: 23.01.2012 16:42:36

Hallo

Ich glaube so kann Dir keiner gezielt helfen.
Eine Beispieldatei mit ein paar Daten und einer Information, was, warum, wohin soll, wäre bestimmt sinnvoll.

Gruß Matthias


  

Betrifft: AW: zeig doch mal ein Bsp. von: Gerhard
Geschrieben am: 23.01.2012 18:36:20

Hallo Matthias,
danke für den Hinweis, ich bin zwar nicht der Jüngste, aber neu im Forum. Ich hoffe, dass mein Beispiel alles sagt. Es ist Kontenblatt, in das alle Bewegungen chronologisch für mehrere Konten eingetragen werden. Ich möchte für die Saldenberechnung nur eine Formel verwenden. Bisher kann ich das nur dadurch erreichen, dass ich die leeren Felder mit Nullen auffülle. Dadurch bleibt der Saldenwert bis zu einem neuen Ereignis solange erhalten, bis ein neuer Wert eingetragen wird. Jetzt möchte ich die Nullen weglassen und doch den neuen Saldenwert ohne zusätzliche Handarbeit erhalten.
Du findest das Beispiel unter https://www.herber.de/bbs/user/78570.xlsx

Danke und Grüße Gerhard


  

Betrifft: Na dann erstmal Willkommen im Forum :o) von: Matthias L
Geschrieben am: 23.01.2012 19:40:55

Hallo

Leider verstehe ich trotzdem noch nicht, was wann wo und warum stehen soll

Gruß Matthias


  

Betrifft: AW: Na dann erstmal Willkommen im Forum :o) von: Josef Ehrensberger
Geschrieben am: 23.01.2012 19:50:06


Hallo Gerhard,

so?

Tabelle1

 ABCDEFGHI
1Beispiel für die Frage: Suche nächste aktive Zelle von Gerhard (GeHi)
2         
3  Konto 1Konto 2Konto 3 
4  einzelnSaldoeinzelnSaldoeinzelnSaldoSaldensumme
5von X1Mi, 22.06.2011300,00 300,00 EUR0,00 0,00 EUR0,00 0,00 EUR300,00 EUR
6von X2Fr, 24.06.2011    1.000,00 1.000,00 EUR1.000,00 EUR
7Umbuchung vom GirokontoDo, 30.06.2011    1.000,00 2.000,00 EUR2.000,00 EUR
8von X3Do, 14.07.2011    300,00 2.300,00 EUR2.300,00 EUR
9von X1Di, 26.07.2011    300,00 2.600,00 EUR2.600,00 EUR
10Umbuchung vom GirokontoFr, 29.07.2011    1.000,00 3.600,00 EUR3.600,00 EUR
11von X2Mi, 03.08.2011    1.000,00 4.600,00 EUR4.600,00 EUR
12von X3Mo, 15.08.2011400,00 700,00 EUR    700,00 EUR
13von X1Mo, 29.08.2011  300,00 300,00 EUR  300,00 EUR
14von X2Di, 30.08.2011    1.000,00 5.600,00 EUR5.600,00 EUR
15Umbuchung vom GirokontoMi, 31.08.2011    1.000,00 6.600,00 EUR6.600,00 EUR
16Umbuchung auf GirokontoFr, 09.09.2011    -500,00 6.100,00 EUR6.100,00 EUR
17Umbuchung auf GirokontoDi, 13.09.2011    -1.000,00 5.100,00 EUR5.100,00 EUR
18von X3Mi, 14.09.2011    300,00 5.400,00 EUR5.400,00 EUR
19von X1Do, 29.09.2011    300,00 5.700,00 EUR5.700,00 EUR

Formeln der Tabelle
ZelleFormel
D5=WENN(C5="";"";SUMME($C$5:C5))
F5=WENN(E5="";"";SUMME($E$5:E5))
H5=WENN(G5="";"";SUMME($G$5:G5))
I5=SUMME(H5;F5;D5)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




« Gruß Sepp »



  

Betrifft: Sorry, sollte zu Gerhard! o.T. von: Josef Ehrensberger
Geschrieben am: 23.01.2012 19:51:34

« Gruß Sepp »



  

Betrifft: AW: Na dann erstmal Willkommen im Forum :o) von: Gerhard
Geschrieben am: 23.01.2012 22:23:53

Hallo Sepp,
vielen Dank, das ist ja so einfach und toll! Eigentlich hätte ich auch darauf kommen sollen. Aber so habe ich wieder etwas gelernt! Auch mit dem Quatsch!

Einen schönen Abend und Grüße Gerhard


  

Betrifft: AW: Na dann erstmal Willkommen im Forum :o) von: Gerhard
Geschrieben am: 23.01.2012 21:23:06

Hallo Matthias und Sepp,
in Spalte A trage ich alle Ereignisse meines Lebens ein und verteile sie dann in die Spalten C, E, G.
Da die Ereignisse nicht jedes Mal alle drei Spalten betreffen, bleiben Zellen in anderen Spalten der gleichen Zeile leer. Beispiel Zeile 12: Eintrag 400 in C12, E12 und G12 bleiben leer.
Jetzt möchte ich die Summe von C5+C12 in D12 sehen und die hier befindliche Formel soll jetzt beide Werte finden.
Da die Zeilen, in denen die zu findenden Zellen sind, nicht gleich weit voneinander entfernt sind (deutlicher zu sehen in den Spalten E und G), muss das in den Formeln der Spalten D, F, H berücksichtigt werden. Ich bräuchte also eine Art "gehe zu" Funktion, die zur nächsten aktiven Zelle springt. Sonst muss ich, wie im vorliegenden Beispiel, jede Formel der Spalten D, F, H bei einem Ereignis individuell anpassen.
Hoffentlich habe ich mich jetzt besser verständlich gemacht!
Grüße Gerhard


  

Betrifft: AW: Na dann erstmal Willkommen im Forum :o) von: Josef Ehrensberger
Geschrieben am: 23.01.2012 21:27:48


Hallo Gerhard,

hast du meinen Vorschlag ausprobiert, da brauchst du nichts anpassen!




« Gruß Sepp »



  

Betrifft: AW: Na dann erstmal Willkommen im Forum :o) von: Gerhard
Geschrieben am: 23.01.2012 22:00:50

Hallo Sepp,

Deinen Vorschlag habe ich nicht erkannt! Tut mir leid! Was hast Du gemeint?



Gruß Gerhard


  

Betrifft: AW: Na dann erstmal Willkommen im Forum :o) von: Josef Ehrensberger
Geschrieben am: 23.01.2012 22:08:23


Hallo Gerhard,

meinen Formelvorschlag von hier https://www.herber.de/forum/messages/1247659.html

da brauchst du nichts anpassen.




« Gruß Sepp »



Beiträge aus den Excel-Beispielen zum Thema "Suche nächste aktive Zelle"