Microsoft Excel

Herbers Excel/VBA-Archiv

Datenzusammenstellung??? | Herbers Excel-Forum


Betrifft: Datenzusammenstellung??? von: Beate
Geschrieben am: 03.02.2012 15:52:55

Liebe Excel-Experten,

ich habe eine Anfrage zu folgender Problematik. In einer Tabelle sind in der ersten Spalte Rezepturnummern eingetragen und in der Kopfzeile alle möglichen Inhaltsstoffe. Pro Rezeptur sind entsprechend der Erfordernis die Gewichte der einzelnen Inhaltsstoffe vermerkt - pro Rezeptur werden durchschnittlich 6 Inhaltsstoffe von ca. 50 möglichen verwendet. Nun möchte ich für die weitere Berechnung aus der Gesamtliste separat eine Zusammenstellung pro Rezeptur und nur über die Inhaltsstoffe, die wirklich erforderlich sind. Ich habe mir das so vorgestellt, dass ich die Rezepturnummer eingebe und dann nur die Inhalte, wozu auch Gewichtsangaben vorhanden sind, angezeigt werden, einschließlich der Gewichte. Ist so etwas mit Excel möglich?

Vielen Dank für die Hilfe.

Herzliche Grüße
Bea

  

Betrifft: AW: Datenzusammenstellung??? von: guentherh
Geschrieben am: 03.02.2012 16:07:35

Ja.



dürfte aber keiner einfach so aus der Hand Schütteln.
Stell doch mal eine Beispieldatei (ggf. mit Phantasiedaten) ein in der die Tabelle und der Ergebnisbereich erkennbar sind.

Gruß,
Günther


  

Betrifft: AW: Datenzusammenstellung??? von: Beate
Geschrieben am: 03.02.2012 17:05:16

Hallo, Günther,

vielen Dank für deine schnelle Antwort. Ich würde mir noch paar Gedanken machen, ob ich generell eine andere Lösung finde, bevor diese Lösung zu aufwendig wird und ich melde mich dazu spätestens am Montag nochmal.

Vielen Dank und ein schönes Wochenende.

Herzliche Grüße
Bea


  

Betrifft: AW: Datenzusammenstellung??? von: Dirk
Geschrieben am: 03.02.2012 17:42:36

Hallo Bea,

Lass dich nichzt verunsichern.
Das ich nicht so schwer wie Günther meint.

ich schick dir in ca 15min einen Vorschlag von mir

Gruß
Dirk


  

Betrifft: AW: Datenzusammenstellung??? von: Beate
Geschrieben am: 03.02.2012 18:28:03

Hallo, Dirk,

herzlichen Dank für dein Hilfeangebot und dann ein schönes Wochenende.

Viele Grüße
Bea


  

Betrifft: AW: Datenzusammenstellung??? von: Josef Ehrensberger
Geschrieben am: 03.02.2012 18:01:44


Hallo Bea,

so?

Tabelle1

 ABCDEFGHIJKLMNO
1RezeptInhalt 1Inhalt 2Inhalt 3Inhalt 4Inhalt 5Inhalt 6Inhalt 7Inhalt 8Inhalt 9Inhalt 10  Rezept9
21 1,05 mg 4,74 mg  2,93 mg  7,09 mg  Inhalt 25,15 mg
323,87 mg  5,54 mg9,02 mg 5,45 mg     Inhalt 46,65 mg
43  1,48 mg1,12 mg  8,90 mg 0,55 mg   Inhalt 66,16 mg
54 1,18 mg7,35 mg  5,54 mg2,86 mg  2,54 mg  Inhalt 81,07 mg
65  1,94 mg  2,80 mg  4,03 mg   Inhalt 105,71 mg
76 1,14 mg  2,08 mg   1,01 mg5,06 mg    
87   8,28 mg   6,55 mg 6,10 mg    
986,66 mg   1,00 mg   8,77 mg     
109 5,15 mg 6,65 mg 6,16 mg 1,07 mg 5,71 mg    
11100,62 mg 8,89 mg 2,33 mg 2,02 mg 3,00 mg     
1211  8,11 mg  7,87 mg3,68 mg  6,03 mg    
1312 1,08 mg 5,01 mg  4,37 mg6,37 mg      
14137,53 mg9,65 mg1,09 mg      3,26 mg    
15141,82 mg5,17 mg       3,47 mg    
16158,92 mg  2,43 mg5,80 mg  2,14 mg7,11 mg     

Formeln der Tabelle
ZelleFormel
N2{=WENN(ZÄHLENWENN(INDEX($B$2:$K$16;VERGLEICH($O$1;$A$2:$A$16;0); ); ">0")<ZEILE(A1); "";INDEX($B$1:$K$1;1;KKLEINSTE(WENN(INDEX($B$2:$K$16;VERGLEICH($O$1;$A$2:$A$16;0); )<>"";SPALTE($A$1:$J$1)); ZEILE(A1))))}
O2=WENN(N2="";"";INDEX($B$2:$K$16;VERGLEICH($O$1;$A$2:$A$16;0); VERGLEICH(N2;$B$1:$K$1;0)))
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Datenzusammenstellung??? von: Beate
Geschrieben am: 03.02.2012 18:25:07

Hallo, Sepp,

vielen lieben Dank für deine Hilfe. Genauso habe ich mir das vorgestellt und ich bin begeistert. Nur noch eine kleine Anfrage. Ist es möglich, die Spalten N und O auf einem separaten Tabellenblatt abzubilden? Falls nicht, geht die Welt auch nicht unter.

Umsetzen werde ich es dann erst am Montag, denn ich verlasse jetzt meinen Arbeitsplatz.

Nochmals herzlichen Dank und ein schönes Wochenende.

Beste Grüße
Bea


  

Betrifft: AW: Datenzusammenstellung??? von: Josef Ehrensberger
Geschrieben am: 03.02.2012 18:31:07


Hallo Bea,

klar geht das, dazu musst du nur die Bezüge auf da entsprechende Tabellenblatt setzen.

Also statt $B$2:$K$16 schreibst du Tabelle3!$B$2:$K$16 und bei den anderen Bezügen ebenso.



« Gruß Sepp »



  

Betrifft: AW: Datenzusammenstellung??? von: Beate
Geschrieben am: 08.02.2012 09:24:41

Hallo, Sepp,

Entschuldigung, dass ich mich so spät erst wieder melde, doch ich hatte einen sehr turbulenten Wochenstart, so dass ich deinen Vorschlag noch gar nicht umsetzen konnte. Ich bin davon überzeugt, dass es klappen wird und möchte mich nochmals ganz herzlich für die großartige Hilfe bedanken.

Beste Grüße
Bea