Microsoft Excel

Herbers Excel/VBA-Archiv

Kombinierte Auswertung Rangliste | Herbers Excel-Forum


Betrifft: Kombinierte Auswertung Rangliste von: Burghard
Geschrieben am: 03.02.2012 18:21:26

Hallo,

ich möchte eine Auswertungstabelle erstellen. Und zwar soll der höchste Wert aus der Spalte B mit dem niedrigsten Wert aus der Spalte B gesucht werden, wenn die Werte jeweils das Merkmal "x" in Spalte C haben.

Die Ausgabe des höchsten Wertes mit dem Merkmal "x" soll in Spalte D geschehen, die Ausgabe des kleinsten Wertes mit dem Merkmal "x" in Spalte E.

Dasselbe gilt für den zweithöchsten, dritthöchsten Wert etc.

Ich scheitere an der Formel.

Anbei ein Beispiel:

https://www.herber.de/bbs/user/78726.xls

Hilfe wäre nett.

Schönen Gruß

Burghard

  

Betrifft: AW: Kombinierte Auswertung Rangliste von: Josef Ehrensberger
Geschrieben am: 03.02.2012 18:28:41


Hallo Bughard,

so?

Tabelle1

 ABCDE
1NameWerteMerkmalAusgabe MaxAusgabe Min
2A10000 CF
3B8000 FC
4C7000x  
5D6000   
6E5000   
7F4500x  
8G4000   
9H3800   
10I3500   
11J2000   

Formeln der Tabelle
ZelleFormel
D2{=WENN(ZÄHLENWENN($C$2:$C$11;"x")<ZEILE(A1); "";INDEX($A$2:$A$11;VERGLEICH(KGRÖSSTE(WENN($C$2:$C$11="x";$B$2:$B$11); ZEILE(A1)); $B$2:$B$11;0)))}
E2{=WENN(ZÄHLENWENN($C$2:$C$11;"x")<ZEILE(A1); "";INDEX($A$2:$A$11;VERGLEICH(KKLEINSTE(WENN($C$2:$C$11="x";$B$2:$B$11); ZEILE(A1)); $B$2:$B$11;0)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Sortierung notwendig von: Burghard
Geschrieben am: 04.02.2012 01:03:11

Hallo Josef,

klappt super. Vielen Dank. Ich habe das Ganze in meiner Beispieltabelle noch etwas ergänzt.

Anstelle der Namen habe ich fortlaufende Zahlen genommen.

Ich habe die Kombination der Max- und Min-Werte addiert. Leider ist dann das Ganze aber nicht in Spalte H größenmäßig geordnet.

Lassen sich die Spalten D-H größenmäßig sortieren (größer Wert aus Spalte H oben)?

Ich vermute mal, dass neben den Spalten D bis H (= Auswertungsspalten) rechts noch weitere Spalten entstehen (die sortierten Spalten D-H) und nachher die Spalten D-H ausgeblendet werden.

Ich habe das so in die Spalten I-M einmal per Hand (ohne Formel) gemacht (= gelb hinterlegter Bereich).

https://www.herber.de/bbs/user/78731.xls


Was mir noch aufgefallen ist, es gibt praktisch doppelte Kombinationen.

Größter Wert + kleinster Wert und kleinster Wert + größter Wert (in der Mitte der Auswertungsspalten sind diese Kombinationen gleich).

Nun wird es richtig kompliziert. Lässt sich die doppelte Ausgabe vermeiden, so dass es nicht die doppelte Anzahl der Kombinationen gibt?

Hilfe wäre nett.

Schönen Gruß

Burghard


  

Betrifft: AW: Sortierung notwendig von: Josef Ehrensberger
Geschrieben am: 04.02.2012 10:26:06



« Gruß Sepp »



  

Betrifft: AW: Sortierung prima, aber ... von: Burghard
Geschrieben am: 04.02.2012 13:03:57

Hallo Josef,

vielen Dank für die schnelle Lösung, das ist genau das, was ich gesucht habe und könnte schon ausreichen, aber gibt es eventuell noch die Möglichkeit, nur eine der beiden Kombinationen, siehe z.B. Spalte I2 bis M3 und gleiche Situation darunter, einzublenden?

35+9 = 7984 und 9+35 = 7984 ist gleich. Ich bräuchte, z.B. nur den Wert 35+9 (also größter + kleinster) = 7984, den anderen Wert (kleinster + größter) in der sortierten Zeile darunter bräuchte ich nicht angezeigt.

Das wäre für mich das Optimum.

Evtl. müsste in einer Zusatzspalte nur der erste, der dritte Spaltenwert angezeigt werden (laienhafter Gedanke von mir). Vielleicht geht das auch gar nicht. Leider keine Ahnung.

Schönen Gruß

Burghard


  

Betrifft: AW: Sortierung prima, aber ... von: Josef Ehrensberger
Geschrieben am: 04.02.2012 13:34:36


Hallo Burghard,

geht auch.

https://www.herber.de/bbs/user/78740.xls


« Gruß Sepp »



  

Betrifft: AW: geht super, aber ... von: Burghard
Geschrieben am: 04.02.2012 21:06:29

Hallo Sepp,

vielen Dank für die Hilfe und die Lösung. Funktioniert einwandfrei, allerdings nur, wenn die Anzahl der "x" in Spalte C immer 18 wäre (das variiert aber). Ich möchte in der Spalte C das Merkmal aber verschieden oft vergeben.

Das Problem ist, dass in den Spalten I bis M die Zeilenanzahl in den Spalten D bis H, die auf der Menge der "x" in Spalte C beruhen, die Zeilenanzahl nicht dynamisch ist (Anzahl der Zeilen bei den Spalten D bis H). Deshalb gibt es dort auch in den Spalten I bis M die Ausgabe "#Wert".

Vielleicht kannst Du ja mal in der Spalte C mehr oder weniger Kreuze setzen (immer gerade Anzahl, z.B. 2,4,6,8, ...) und gucken, wie die Spalten I bis M sich verhalten und ob/wie das "#Wert" unterdrückt werden kann.

https://www.herber.de/bbs/user/78743.xls

Ich habe befürchtet, dass es so kompliziert ist.

Vielleicht kannst Du das auch noch hinkriegen?

Schönen Gruß

Burghard


  

Betrifft: AW: geht super, aber ... von: Josef Ehrensberger
Geschrieben am: 04.02.2012 22:35:53


Hallo Burghard,

ich habe jetzt die Formeln komplett umgestellt, die Hilfsspalten braucht es nicht mehr, und es werden zahlen von 0 bis 10.000 richtig gerechnet. Schau ob das so passt.

https://www.herber.de/bbs/user/78744.xls



« Gruß Sepp »



  

Betrifft: AW: 100% von: Burghard
Geschrieben am: 05.02.2012 13:00:21

Hallo Sepp,

100% genau das, was ich gesucht habe. Vielen, vielen Dank für die viele Arbeit und Mühe!

Schönen Gruß

Burghard


Beiträge aus den Excel-Beispielen zum Thema "Kombinierte Auswertung Rangliste "