Microsoft Excel

Herbers Excel/VBA-Archiv

Berechnung | Herbers Excel-Forum


Betrifft: Berechnung von: JoWe
Geschrieben am: 03.02.2012 23:00:58

Hallo Formelakrobaten,
in der Tabelle soll der Treibstoffverbrauch berechnet werden. Wird vollgetankt, kann der leicht errechnet werden. wenn jedoch nicht vollgetankt wird ist der Verbrauch nur zu errechnen, wenn die Laufleistung vom letzten Volltanken bis zum nächsten Volltanken mit der innerhalb dieser Zeiten getankten Gesamtspritmenge berücksichtigt wird.
Es fällt mit schwer das Ziel zu erklären, vermutlich komme ich aus eben diesem Grund auch nicht auf die Lösung. Bitte um Hilfe....

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDE
1DatumkmLitervollgetanktVerbrauch
2 24323   
323.01.20122500352ja 
427.01.20122543023nein 
530.01.20122555635ja 
601.01.20122609855nein 
702.02.2012262348nein 
803.12.20022688548ja 

Gruß
Jochen

  

Betrifft: AW: Berechnung von: Josef Ehrensberger
Geschrieben am: 03.02.2012 23:36:31


Hallo Jochen,

Tabelle5

 ABCDEFG
1DatumkmLitervollgetanktVerbrauchHilfsspalten 
2 24323     
323.01.20122500352ja7,6568052
427.01.20122543023nein   
530.01.20122555635ja10,4955358
601.01.20122609855nein   
702.02.2012262348nein   
803.12.20022688548ja8,351329111

Formeln der Tabelle
ZelleFormel
E3=WENN(D3="ja";G3/F3*100;"")
F3=WENN(D3="ja";B3-$B$2-SUMME($F$2:F2); "")
G3=WENN(D3="ja";SUMME($C$3:C3)-SUMME($G$2:G2); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Berechnung von: JoWE
Geschrieben am: 04.02.2012 15:28:21

Hallo Sepp,

vielen Dank - offenbar war mein Fehler alles in einer Zelle statt mit Hilfsspalten lösen wollen.

Gruß
Jochen


  

Betrifft: Nicht unbedingt! Das geht sicher auch ohne ... von: Luc:-?
Geschrieben am: 05.02.2012 00:08:14

…Hilfsspalten, Jochen,
aber so ist es für dich und Kollegen sicher (gewohnt) übersichtlicher. Statt Hilfszellen zu verwenden, könntest du deren Fmln (bestimmt) auch benennen und dann die Namen in E3ff verwenden.
Gruß+schöSo, Luc :-?


Beiträge aus den Excel-Beispielen zum Thema "Berechnung"