Microsoft Excel

Herbers Excel/VBA-Archiv

durschnittl. Besuchfrequenz | Herbers Excel-Forum


Betrifft: durschnittl. Besuchfrequenz von: Stefan
Geschrieben am: 16.02.2012 10:36:20

Hallo,
ich habe schon einige Sachen ausprobiert, bekomme es aber irgendwie nicht hin.
In Spalte A habe ich ca. 5000 Zeilen mit ca. 80 Kundennamen gefüllt. Die Kunden werden grundsätzlich mehrfach aufgeführt. In Spalte B habe ich das Besuchsdatum (immer Mo.-Sa.) für das komplette Jahr 2011.
Nun möchte ich pro Kunde und pro Kalendermonat (Jan. bis Dez.) die durchschnittliche Besuchfrequenz pro Woche ermitteln.
Bsp.
Kunde Müller: Jan. 3,2 Tage durchschnittl./Woche
Kunde Müller: Feb. 1,9 Tage durchschnittl./Woche
Kunde Meier: Juli. 4,1 Tage durchschnittl. /Woche
usw.
Die Darstellung ist relativ felxibel, ich möchte nur einfach pro Kunde und pro Monat die durschnittl. Wochen-Besuchsfrequenz anhand des Datums ermitteln.

Vielen Dank für Eure Unterstützung im Voraus.

Gruß,
Stefan

  

Betrifft: AW: durschnittl. Besuchfrequenz von: JoWE
Geschrieben am: 16.02.2012 11:36:59

Hallo Stefan,
im ersten Moment würde ich mal auf eine Pivottabelle setzen.
Ohne Beispieltabelle aber schwer zu sagen.
Gruß
Jochen


  

Betrifft: AW: durschnittl. Besuchfrequenz von: ingoG
Geschrieben am: 16.02.2012 11:37:37

Hallo Stefan,

in einem neuen Blatt stehen in in B2 der Kundenname und in B2 der zu betrachtende Monat (zB Januar).
in B1 steht das betrachtete Jahr zB 2011.

dann kannst Du in C2 folgende Formel eintragen:

=RUNDEN(SUMMENPRODUKT((A2=Daten!$A$1:$A$1000)*(B2=TEXT(Daten!$B$1:$B$1000;"MMMM")) *($B$1=JAHR(Daten!$B$1:$B$1000)))/(TAG(DATUM($B$1;MONAT(DATWERT("1."&B2&"."&$B$1))+1;0))/7);1) 
Ich hoffe, das hilft Dir weiter

Gruß Ingo
PS eine Rückmeldung wäre nett...


  

Betrifft: AW: durschnittl. Besuchfrequenz von: Stefan
Geschrieben am: 16.02.2012 20:00:26

Hallo,

über PIVOT habe ich es auch schon versucht,...da konnte ich jedoch nur gruppieren, aber keine vernünftigen durchschnittswerte ermitteln.
die antwort von ingo finde ich recht schick, wobei da der fehler #WERT! angezeigt wird.
ich vermute mal, dass du bzgl. des neuen blattes den kundennamen in A2 meinst und nicht B2?
sonst habe ich das basisblatt noch in "Daten" umbenannt,...wg. dem bezug in der formel.
trotzem,...fehlermeldung?!?

kennt jemand die ursache?


  

Betrifft: AW: durschnittl. Besuchfrequenz von: Christian
Geschrieben am: 16.02.2012 11:46:34

hallo Stefan,
Ich schlage vor:
- Schreibe zB in F1 den Monat "Feb 12", in E2 bis E81 deine 80 Namen
- Dann ermitteltst du die Anzahl der Besuche pro Monat für jeden Namen mit SUMMENPRODUKT (z.B in F2 bis F81)
- als nächstes bestimnmst du die Anzahl der Tage für den gewählten Monat - für "Feb 12" also 29 (zB. in G1)

Das Ergebnis ist dann "Anzahl der Besuche" / "Anzahl Tage des Monat" * 7 (z.B in G2 bis G81)

Gruß
Christian