Microsoft Excel

Herbers Excel/VBA-Archiv

Nettoarbeitstage | Herbers Excel-Forum


Betrifft: Nettoarbeitstage von: Mat
Geschrieben am: 20.02.2012 14:13:50

Hallo Leute,

ich berechnet die Anzahl von Urlaubstagen zwischen zwei Zellen mit folgender Formel:

=NETTOARBEITSTAGE(A19;B19;FT!A$4:A$19) (Im Tabellenblatt FT stehen die Feiertage.)

Mein Problem ist, dass bei Leerzellen der Wert 1 in der Formelzelle angzeigt wird. Wie kann ich das verhindern?

Gruß Mat

  

Betrifft: AW: Nettoarbeitstage von: hary
Geschrieben am: 20.02.2012 15:28:42

Hallo Mat
Kannst Du mit Anzahl oder eine Wenn abfrage vorsetzen.

Tabellenblattname: Tabelle1

 

A

B

C

1

01.01.2012

10.01.2012

7

2

02.02.2012

 

 


Benutzte Formeln:
C1: =WENN(ANZAHL(A1:B1)=2;NETTOARBEITSTAGE(A1;B1);"")
C2: =WENN(ANZAHL(A2:B2)=2;NETTOARBEITSTAGE(A2;B2);"")
gruss hary


  

Betrifft: AW: Nettoarbeitstage von: Mat
Geschrieben am: 21.02.2012 09:05:39

Hallo Harry,

leider werden bei der Formel die Feiertage mitgezählt.

Gruß Mat


  

Betrifft: AW: Nettoarbeitstage von: hary
Geschrieben am: 21.02.2012 10:46:19

Hallo
Du brauchst doch nur Deine Formel einzusetzen.

Tabelle2

 ABCDE
101.01.201205.01.20123  Feiertage Bsp.
202.01.2012      03.01.2012
303.01.201210.01.20126  08.01.2012
404.01.2012       
505.01.2012       
606.01.2012       

verwendete Formeln
Zelle Formel Bereich
C1 =WENN(ANZAHL(A1:B1)=2;NETTOARBEITSTAGE(A1;B1;E2:E3);"") 
C2 =WENN(ANZAHL(A2:B2)=2;NETTOARBEITSTAGE(A2;B2;E3:E4);"") 
C3 =WENN(ANZAHL(A3:B3)=2;NETTOARBEITSTAGE(A3;B3;E4:E5);"") 
C4 =WENN(ANZAHL(A4:B4)=2;NETTOARBEITSTAGE(A4;B4;E5:E6);"") 
C5 =WENN(ANZAHL(A5:B5)=2;NETTOARBEITSTAGE(A5;B5;E6:E7);"") 
C6 =WENN(ANZAHL(A6:B6)=2;NETTOARBEITSTAGE(A6;B6;E7:E8);"") 

Tabellendarstellung in Foren Version 5.30


gruss hary


  

Betrifft: AW: nochmal neu von: hary
Geschrieben am: 21.02.2012 10:48:21

Hallo
Du brauchst doch nur Deine Formel einzusetzen.

Tabelle2

 ABCDE
101.01.201205.01.20123  Feiertage Bsp.
202.01.2012      03.01.2012
303.01.201210.01.20125  08.01.2012
404.01.2012       
505.01.2012       
606.01.2012       

verwendete Formeln
Zelle Formel Bereich
C1 =WENN(ANZAHL(A1:B1)=2;NETTOARBEITSTAGE(A1;B1;$E$2:$E$3);"") 
C2 =WENN(ANZAHL(A2:B2)=2;NETTOARBEITSTAGE(A2;B2;$E$2:$E$3);"") 
C3 =WENN(ANZAHL(A3:B3)=2;NETTOARBEITSTAGE(A3;B3;$E$2:$E$3);"") 
C4 =WENN(ANZAHL(A4:B4)=2;NETTOARBEITSTAGE(A4;B4;$E$2:$E$3);"") 
C5 =WENN(ANZAHL(A5:B5)=2;NETTOARBEITSTAGE(A5;B5;$E$2:$E$3);"") 
C6 =WENN(ANZAHL(A6:B6)=2;NETTOARBEITSTAGE(A6;B6;$E$2:$E$3);"") 

Tabellendarstellung in Foren Version 5.30


gruss hary


Beiträge aus den Excel-Beispielen zum Thema "Nettoarbeitstage"