Listeneinträge vergleichen



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Listeneinträge vergleichen
von: Stefan
Geschrieben am: 29.05.2002 - 10:26:41

Hallo!

Ich müßte prüfen, ob Kunden in einer Tabelle (Versicherung) in einer anderen Tabelle (Bank) ebenfalls vorkommen, wobei in der Versicherungstabelle ein Kunde öfter als 1x bei einem Insitut UND bei mehreren Instituten vorkommen kann.

Wenn ich es nach der Formel: =WENN(ZÄHLENWENN(Tabelle1A$1:A1;Tabelle2A1)>1;"VORHANDEN";NICHT VORHANDEN"") mache, zeigt er mir grundsätzlich an, dass alle Versichungskunden einen Bankvertrag haben, obwohl dies nicht zutrifft. Lässt sich Text nicht zählen, bzw. zeigt er mir durch diese Formel nicht auch Kunden als vorhanden an, wenn sie in der Banktabelle schon 2x vorkommen?

Kennt wer eine alternative Lösung?

Danke für die Hilfe und beste Grüße
Stefan


Beispiel:

Banktabelle:

Müller Hans Bank1
Paul Huber Bank2

Prüfen, ob Bankkunde in Versicherungstabelle vorhanden:

Müller Hans Versicherung1 VORHANDEN
Müller Hans Versicherung2 VORHANDEN
Meier Gerhard Versicherung3 NICHT VORHANDEN



nach oben   nach unten

Re: Listeneinträge vergleichen
von: MikeS
Geschrieben am: 29.05.2002 - 11:06:19

Hallo Stefan,

ich hab`s mal mit einer SVerweis versucht.

In Tabelle1-A2:A12 stehen die Zahlen 1 bis 11
In Tabelle2-A2:A10 steht z.B. die Zahl 8

Die SVerweis-Formel prüft nun, ob die Zahlen in Tabelle1
auch in der Tabelle2 vorkommen und schreibt dementsprechend "vorhanden" oder "nicht vorhanden" in die Zelle.

Die Formel mußt Du nur noch nach unten kopieren.

MS Excel von MikeS an Stefan
 AB
11=WENN(ISTFEHLER(SVERWEIS(A2;Tabelle2!$A$2:$A$10;1;0));"NichtVorhanden";"vorhanden")
22 
33 
44 
55 
66 
77 
88 
99 
1010 
1111 


War`s das???

Ciao MikeS

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Listeneinträge vergleichen"