Microsoft Excel

Herbers Excel/VBA-Archiv

Zusammenfassung PLZ Gebiete



Excel-Version: 8.0 (Office 97)

Betrifft: Zusammenfassung PLZ Gebiete
von: Hanna
Geschrieben am: 03.06.2002 - 15:45:13

Hallo,

ich habe einen Umsatzübersicht, die ich nach PLZ-Gebieten (die ersten 2 Stellen der PLZ) summieren will. Mit Teilergebnisse kriege ich das Ergebnis für jede einzelne PLZ.

Wie reduziere ich zB. 34052 auf 34? oder stelle eine Bedingung Summe von 34000 bis 34999?

Danke im Voraus sacht Hanna


  

Re: Zusammenfassung PLZ Gebiete
von: @lex
Geschrieben am: 03.06.2002 - 16:10:36

Hallo Hanno !
Wie folgt:
Wenn Die PLZ als Zahlen formatiert sind Format "00000" und die PLZ in Spalte a1:a16 stehen,
dann hilft Dir folgende Formel
{=SUMME(WENN(A1:A16>32000;WENN(A1:A16<33000;B1:B16;"")))}
bei PLZ von de Kolleschen dann eben:
{=SUMME(WENN(A1:A16>1000;WENN(A1:A16<2000;B1:B16;"")))}

Die geschweiften Klammern nicht mit eingeben:
Die Formel mit Strg+Shift+Enter abschliessen, um die geschweiften Klammern zu erzeugen.

VG,
Alex

  

noch ein Vorschlag
von: MikeS
Geschrieben am: 03.06.2002 - 16:25:46

Hi Hanna,


MS Excel von MikeS an @lex
 AB
1PLZWert
250000200
325000100
434000100
534100100
6200{=SUMME(WENN(LINKS(A2:A5;2)="34";B2:B5;0))}


In diesem Beispiel werden nur die Zahlen summiert,
die im PLZ-Bereich mit 34 beginnen (Summe= 200).

Die geschweifte Klammer nicht eingeben, sondern die
Formel mit Strg+Shift+Eingabe in die Zelle schreiben.

Ciao MikeS

 

Beiträge aus den Excel-Beispielen zum Thema "Zusammenfassung PLZ Gebiete"