Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMEWENN



Excel-Version: 8.0 (Office 97)

Betrifft: SUMMEWENN
von: Stefan F
Geschrieben am: 07.06.2002 - 10:59:10

Salute!

In Spalten A-C habe ich verschiedene Inhalte (A=Monat, B=Umsatz, C=Name).

Mit
SummeWenn(A2:C11;"Januar";B2:B11)
wird eine Summe für den Monat Januar gebildet.

Wie muss ich den Ausdruck ergänzen, um die Summe nur zu erhalten, wenn in Spalte C der Name "Meier" genannt ist?

Vielen Dank schon mal für Eure Zeit und Mühe!

Viele Grüsse

Stefan F

  

Re: SUMMEWENN
von: Frederik
Geschrieben am: 07.06.2002 - 11:10:59

Hallo!

Vielleicht indem du 2 wenn - formeln draus machst?!

Wenn(A2:C11 = "Januar";wenn(c2:c11 = "meier";summe(b2:b11));"")

Gruß
Frederik

  

Re: SUMMEWENN
von: Claudia
Geschrieben am: 07.06.2002 - 11:26:03

Hallo Stefan,

evtl. könntest Du auch die Funktion SUMMEPRODUKT verwenden
>> In Spalten A-C habe ich verschiedene Inhalte (A=Monat, B=Umsatz, C=Name).

=SUMMENPRODUKT((A1:A30="Januar")*(C1:C30="Meier");$B$1:$B$30)

Da erhälst Du jetzt die Summe von Januar nur für Meier.

Herzliche Grüße
Claudia

  

Vielen, vielen Dank!
von: Stefan F.
Geschrieben am: 07.06.2002 - 11:50:06

Klasse, es funktioniert!

Ich wünsche Euch schon mal ein schönes Wochenende!

Stefan F.


  

Re: SUMMEWENN
von: Arnim
Geschrieben am: 07.06.2002 - 11:53:05

Hallo Stefan,

mein Vorschlag:
Schreibe in D1 Überschrift "Monat", in E1, F1 usw. die Namen.
In d2 bis D13 die Zahlen für die Monate, also 1, 2 usw (kanst auch Format "Datum" "A" für April usw nehmen).
In E2 gebe folgende Array-Formel ein:
=SUMME((MONAT($A$2:$A$1000)=$D2)*($C$2:$C$1000=E$1)*$B$2:$B$1000)
Eingabe der Formel mit Tasten "Strg"+"Shift" und dann erst "Enter".
Kopiere die Formel bis E13 herunter und dann nach rechts für die anderen Namen.
Du kannst auch diese Formel nehmen - nur mit Eingabe "Enter":
=SUMMENPRODUKT((MONAT($A$2:$A$1000)=$D2)*($C$2:$C$1000=E$1)*$B$2:$B$1000)

Gruß Arnim

 

Beiträge aus den Excel-Beispielen zum Thema "SUMMEWENN"