Microsoft Excel

Herbers Excel/VBA-Archiv

mit privot tabelle ? oder ...? | Herbers Excel-Forum


Betrifft: mit privot tabelle ? oder ...? von: buliwyf
Geschrieben am: 10.08.2012 15:43:50

Hallo Freunde,

in der folgenden Liste moechte ich die rechts aufgefuehrten KDNR in der Spalte C ohne doppelte Aufzaehlung aufgelistet haben.
Desweiteren hat jeder Kunde eine gewisse Anzahl von Aktionen die in den Zellen E3 bis Y3 beschrieben stehen.
Hier soll nun jeder Kunde ein Kreuzchen (x) bekommen wenn er eine Aktion hat.

Als Beispiel: Kunde 1001 hat die AKtionen 3 und 24.
Nun muesste er ein Kreuz in der Spalte F5 und S5 bekommen. (da ja in der Zelle C5 dieser Kunde steht)

Ich haenge mal am besten die datei mit ran sonst kann sich glaube ich keiner vorstellen was ich meine.
https://www.herber.de/bbs/user/81370.xls

Vielleicht kann mir ja jemand helfen ?

Danke !

Lg stef

  

Betrifft: AW: mit privot tabelle ? oder ...? von: buliwyf
Geschrieben am: 10.08.2012 15:53:42

Edit : ALso der erste Schritt waere die KDNR aus der Spalte AH5:AH45 NICHT doppelt und dreifach
in der Spalte C5: zu kopieren...?
Und der zweite Schritt waere dann zu pruefen ueber eine Matrix evtl. ? Welche KDNR welche Aktion hat und diese dann per "x" in die Zellen C5:AA5 usw einzutragen.
In der excel tab geht das noch per hand, aber die richtge ist viel groesser. :-(

Lg stef


  

Betrifft: AW: ohne Pivot, nur Formeln von: Sheldon
Geschrieben am: 10.08.2012 16:13:18

Hallo stef,

das geht folgendermaßen:

In Zelle C5: =MIN(AH5:AH45)
In Zelle C6: =WENN(MAX(C$5:C5)=MAX(AH:AH);"";KGRÖSSTE(AH:AH;ZÄHLENWENN(AH:AH;">"&C5)))
und runterkopieren (siehe auch http://excelformeln.de/formeln.html?welcher=194)

Für die x bei den Aktionen in Zelle E5: =WENN(SUMMENPRODUKT(($AH$1:$AH$1000=$C5)*($AI$1:$AI$1000=E$4))>0;"x";"")
und nach rechts und unten kopieren. Siehe auch http://www.excelformeln.de/formeln.html?welcher=273

Gruß
Sheldon


  

Betrifft: AW: ohne Pivot, nur Formeln von: buliwyf
Geschrieben am: 16.08.2012 15:49:08

Hallo Sheldon,

genau das habe gesucht ! Vielen Dank, it works.....

Super !

Danke.

/Stefan


  

Betrifft: Danke für die RM:-) owT von: Sheldon
Geschrieben am: 16.08.2012 15:55:23

Gruß
Sheldon


Beiträge aus den Excel-Beispielen zum Thema "mit privot tabelle ? oder ...?"