Microsoft Excel

Herbers Excel/VBA-Archiv

Statistik | Herbers Excel-Forum


Betrifft: Statistik von: Ralph
Geschrieben am: 14.08.2012 17:42:46

Hallo Forum,

ich brauche dringend eure hilfe.
habe meine datei angehängt.

in tabelle 1 stehen zimmernr,name,ankunft,abreise,erwachsene,kinder

jetzt möchte ich in tabelle2 stehen haben wieviele übernachtungen ich z.b. im januar hatte.
es gibt aber gäste die im dezember angereist sind und erst im januar abgereist sind und da brauche ich dann nur die übernachtungen im januar.

danke für eure hilfe
Ralph

https://www.herber.de/bbs/user/81422.xlsm

  

Betrifft: AW: Statistik von: Josef Ehrensberger
Geschrieben am: 14.08.2012 18:20:21


Hallo Ralph,

das würde ich mit Hilfsspalten lösen.

https://www.herber.de/bbs/user/81423.xlsm





« Gruß Sepp »



  

Betrifft: AW: Statistik von: Ralph
Geschrieben am: 14.08.2012 20:23:20

Hallo Sepp,

tausen dank, perfekt so

Gruß Ralph


  

Betrifft: vielleicht einfacher von: Erich G.
Geschrieben am: 15.08.2012 01:01:34

Hi Sepp,
spricht etwas dagegen, die Formel in K2 durch die in J2 zu ersetzen?

 JK
244

Formeln der Tabelle
ZelleFormel
J2=WENN(UND(C2>0;D2>0); MAX(;MIN(_Ende;D2)-MAX(_start;C2)); 0)
K2=WENN(UND(C2>0;D2>0); MAX(0;SUMMENPRODUKT((ZEILE(INDEX(A:A;C2):INDEX(A:A;D2))>=_start)*(ZEILE(INDEX(A:A;C2):INDEX(A:A;D2))<=_Ende))-1); 0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: Korrektur von: Erich G.
Geschrieben am: 15.08.2012 01:30:44

Hi Sepp und Ralph,
der Name _Ende muss m. E. etwas anders definiert werden - hier wie _EndN, sonst hat der Juni nur 29 Tage...

 BCDEFGHIJK
1NameAnreiseAbreiseErwachseneKinder_start_Ende/N Hilfsspalten
2abc15.05.201217.07.20121 01.06.201230.06.2012 2929
3def15.05.201217.07.20121 01.06.201201.07.2012 3030

Formeln der Tabelle
ZelleFormel
G2=_start
H2=_Ende
J2=WENN(UND(C2>0;D2>0); MAX(;MIN(_Ende;D2)-MAX(_start;C2)); 0)
K2=WENN(UND(C2>0;D2>0); MAX(0;SUMMENPRODUKT((ZEILE(INDEX(A:A;C2):INDEX(A:A;D2))>=_start)*(ZEILE(INDEX(A:A;C2):INDEX(A:A;D2))<=_Ende))-1); 0)
G3=_start
H3=_EndN
J3=WENN(UND(C3>0;D3>0); MAX(;MIN(_EndN;D3)-MAX(_start;C3)); 0)
K3=WENN(UND(C3>0;D3>0); MAX(0;SUMMENPRODUKT((ZEILE(INDEX(A:A;C3):INDEX(A:A;D3))>=_start)*(ZEILE(INDEX(A:A;C3):INDEX(A:A;D3))<=_EndN))-1); 0)
Namen in Formeln
ZelleNameBezieht sich auf
G2_start=DATWERT("01."&Tabelle2!$B$2&"."&Tabelle2!$B$1)
H2_Ende=DATUM(JAHR(_start);MONAT(_start)+1;0)
J3_EndN=DATUM(Tabelle2!$B$1;MONAT(_start)+1;1)

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: noch Klärungsbedarf von: Erich G.
Geschrieben am: 15.08.2012 06:19:33

Hi Sepp und Ralph,
es besteht m. E. noch Klärungsbedarf.

Beim Monatswechsel gehört ein Teil der Nacht zum alten, ein Teil zum neuen Monat.
Zu welchem Monat soll diese Nacht dann gezählt werden?
Anders ausgedrückt:
Soll der Anreisetag oder der Abreisetag mitgezählt werden?
Anders ausgedrückt:
Sollen (Vollpension mal vorausgesetzt :-) ) die ausgegebenen Abendessen gezählt werden oder die Frühstücke?

Hier sieht man den Unterschied am Beispiel:

 ABCDEFGHI
1AnreiseAbreiseNächte 01.05.201201.06.201201.07.2012  
230.06.201201.07.20121 010 (Abendessen)
329.05.201203.07.201235 3302 (Abendessen)
4         
530.06.201201.07.20121 001 (Frühstücke)
629.05.201203.07.201235 2303 (Frühstücke)
7  gesamt im Maiim Juniim Juli  

Formeln der Tabelle
ZelleFormel
C2=B2-A2
E2=MAX(;MIN(F$1;$B2)-MAX(E$1;$A2))
C3=B3-A3
E3=MAX(;MIN(F$1;$B3)-MAX(E$1;$A3))
C5=B5-A5
E5=MAX(;MIN(F$1;$B5+1)-MAX(E$1;$A5+1))
C6=B6-A6
E6=MAX(;MIN(F$1;$B6+1)-MAX(E$1;$A6+1))

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich