Microsoft Excel

Herbers Excel/VBA-Archiv

Formel oder Makro? | Herbers Excel-Forum


Betrifft: Formel oder Makro? von: Alexandra
Geschrieben am: 15.08.2012 10:37:17

Hallo

Das Forum wurde mir von einem Kollegen Empfohlen.
Naja ich habe auch gerade ein etwas komplexes Problem, vielleicht kann mir jemand weiter helfen.

Ich suche ein Makro das mir folgende Kriterien erfüllt:

Ich habe eine Blatt wo folgende Daten sind:

Spalte A Datum
Spalte H ein Name
Spalte I eine Zahl

Nun soll auf einem 2ten Blatt dies sortiert ausgegeben werden.

und zwar immer nach den letzten 12 Monaten

Ich habe mal eine Beispielsdatei hochgeladen. Hoffentlich ist es verständlich und jemand kann mir weiter helfen, oder könnte man das mit Formel lösen?

https://www.herber.de/bbs/user/81434.xlsx

Danke und Gruss

Alexandra

  

Betrifft: Formeln von: Erich G.
Geschrieben am: 15.08.2012 11:01:09

Hi Alexandra,
meinst du das so?

 ABC
4Fritz  
5MonatAnzahlStk
601.08.201229
701.07.201200
8Jun 1200
9Mai 1200
10Apr 1200
11Mrz 1200
12Feb 1211
13Jan 1200
14Dez 1100
15Nov 11162
16Okt 1100
17Sep 1100
18   
19Hans  
2001.08.2012140
2101.07.201200
22Jun 1200
23Mai 1200
24Apr 12110
25Mrz 12125
26Feb 12121
27Jan 1200
28Dez 1100
29Nov 1100
30Okt 1100
31Sep 1100

Formeln der Tabelle
ZelleFormel
A6=HEUTE()-TAG(HEUTE())+1
B6=SUMMENPRODUKT((Tabelle1!$H$2:$H$17=$A$4)*(TEXT(Tabelle1!$A$2:$A$17;"JJJMM")=TEXT(A6;"JJJMM")))
C6=SUMMENPRODUKT((Tabelle1!$H$2:$H$17=$A$4)*(TEXT(Tabelle1!$A$2:$A$17;"JJJMM")=TEXT(A6;"JJJMM")); Tabelle1!$I$2:$I$17)
A7=A6-TAG(A6-1)
A8=A7-TAG(A7-1)
A20=A6
B20=SUMMENPRODUKT((Tabelle1!$H$2:$H$17=$A$19)*(TEXT(Tabelle1!$A$2:$A$17;"JJJMM")=TEXT(A20;"JJJMM")))
C20=SUMMENPRODUKT((Tabelle1!$H$2:$H$17=$A$19)*(TEXT(Tabelle1!$A$2:$A$17;"JJJMM")=TEXT(A20;"JJJMM")); Tabelle1!$I$2:$I$17)
A21=A7
A22=A8


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Formeln von: Alexandra
Geschrieben am: 15.08.2012 11:24:51

super genau das habe ich gesucht. ist es schwehr dies auf VBA zu schreiben?

gruss


  

Betrifft: AW: Formeln von: Erich G.
Geschrieben am: 15.08.2012 11:41:20

[mal auch ohne Anrede]

"ist es schwehr dies auf VBA zu schreiben?" Für mich wohl nicht.
Ob für dich, vermag ich nicht zu sagen, das hängt von deinem Kenntnisstand ab.
(Mit "Excel gut" hättest du die Formeln hinschreiben können.)

Was genau meintest du denn mit "dies"?
Sollten per VBA die Werte in die Zellen geschrieben werden, wo derzeit die Formeln stehen?
Oder sollten per VBA die Formeln in die Zellen geschrieben werden?

[auch gruss]


  

Betrifft: einfacher mit Pivottabelle von: Erich G.
Geschrieben am: 15.08.2012 11:15:08

Hi Alexandra,
üblicherweise erledigt man solche Auswertungen geschickter mit einer Pivottabelle.
Das Layout ist schöner als hier dargestellt:

 ABCDE
2     
3   Werte 
4NameJahreDatumAnzahl von STKSumme von STK2
5Alex2012Mai13
6  Aug121
7Alex Ergebnis  224
8Franz2012Jul1358
9  Aug11
10Franz Ergebnis  2359
11Fritz2011Nov162
12 2012Feb11
13  Aug19
14Fritz Ergebnis  372
15Hans2012Feb121
16  Mrz125
17  Apr110
18  Aug140
19Hans Ergebnis  496
20Jakob2012Mrz15
21Jakob Ergebnis  15
22Sepp2012Feb145
23Sepp Ergebnis  145
24Verena2012Jan12
25  Jul12
26Verena Ergebnis  24
27Gesamtergebnis  15605

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


Beiträge aus den Excel-Beispielen zum Thema "Formel oder Makro?"