Microsoft Excel

Herbers Excel/VBA-Archiv

externe Daten löscht regel | Herbers Excel-Forum


Betrifft: externe Daten löscht regel von: Alexandra
Geschrieben am: 16.08.2012 16:16:37

Hallo Zusammen

ich denke für euch Profis keine Sache aber ich habe folgendes Problem.

In der Spalte U habe ich eine einfache Regel die mir die Zelle Grün färbt wen das Datum in Spalte A in den letzten 12 Monaten liegt.

Das schaut dann so aus:

=WENN($A1+365>HEUTE();1;0)

wird angewendet auf
=$U:$U
Gut soweit. Das Problem ist das die Daten aus einer DB kommen und immer wieder aktualisiert werden , die Regel wird aber nicht für die neuen Daten übernommen. Jemand eine Idee wie man das lösen könnte?

Oder habe ich sonst ein Fehler drin?

Gruss Alexandra

  

Betrifft: AW: externe Daten löscht regel von: Peter Kloßek
Geschrieben am: 16.08.2012 17:54:29

Hallo Alexandra,

ich gehe mal davon aus, dass Du die Daten aus der Datenbank auf irgendeine Weise in das Excel-Spreadsheet hereinholst oder als eine Text-Datei importierst. Somit kann in diesem Spreadsheet die Regel (Spalte "U") noch gar nicht vorhanden sein. Es gibt m. E. zwei Möglichkeiten, das Problem zu lösen:

1. Du erstellst eine Excel-Datei mit den vorgesehenen Bereichen für die Daten aus der Datenbank und der Spalte "U" mit den Regeln und kopierst bei jeder Aktualisierung die Daten aus der Datenbank in die in der Excel-Datei vorgesehenen Bereiche.

2. Du holst die Daten aus der Datenbank (als Text-Datei) in ein Excel-Spreadsheet und kopierst aus einer Vorlagendatei die Spalte "U" hinzu. Die so ergänzte Datei sollte man als Excel-Datei speichern.

Viele Grüße

Peter Kloßek


  

Betrifft: AW: externe Daten löscht regel von: {Boris}
Geschrieben am: 16.08.2012 18:44:37

Hi Alexandra,

Deine Daten kommen in Spalte A an? Kommen sie auch wirklich als ZAHLEN an und nicht als Text (passiert bei Importen häufig)?

VG, Boris


  

Betrifft: Sorry - sollte gar nicht gesendet werden... von: {Boris}
Geschrieben am: 16.08.2012 18:45:45

...der Browser macht mich grad ein wenig fertig...

VG, Boris


Beiträge aus den Excel-Beispielen zum Thema "externe Daten löscht regel"