Summenfunktion



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Summenfunktion
von: Robert Heusmann
Geschrieben am: 13.06.2002 - 11:28:29

Guten Morgen liebe Excel-Gemeinde,

ich habe eine Frage bezüglich einer Summenfunktion. Wie kann ich folgende Funktion in einer Zelle abbilden?

Summe von i=1 bis 12 von (ZelleB5*(1+ZelleA1/12*i))

Natürlich kann man das ganze auch zu Fuß eingeben, nur wird das bei größeren Summenzählern sehr aufwendig. Hat jemand von Ihnen eine Lösung parat?

Herzlichen Dank

Grüße
Robert Heusmann


nach oben   nach unten

Re: Summenfunktion
von: Andreas
Geschrieben am: 13.06.2002 - 12:37:44

Hallo Robert,

diese Formel hier ist eine Array-Formel, also mit STRG+SHIFT+ENTER abschließen:
=SUMME(B5*(1+A1/12*ZEILE(1:12)))

Viel Spaß,
Andreas

nach oben   nach unten

Re: Summenfunktion
von: Robert Heusmann
Geschrieben am: 13.06.2002 - 13:18:03

Hallo Andreas,

vielen Dank für den Tip. Eine Frage habe ich jedoch. Der Part mit der Zeile ist mir nicht klar. Im Prinzip soll die Rechnung zwölf mal ausgeführt werden, wobei i jedesmal eins größer wird, deswegen die Summe von i=1 bis 12. Das Ergebnis der Rechnung müßte eigentlich bei B5=100 und A1=0,06 = 1293 sein. Kannst Du mir helfen?

Vielen Dank

Grüße
Robert


nach oben   nach unten

Re: Summenfunktion
von: Andreas
Geschrieben am: 13.06.2002 - 13:39:52

Hallo Robert,

bei der Formel =SUMME(B5*(1+A1/12*ZEILE(1:12))) kommt ja auch 1293 heraus!!!
Du mußt sie nicht mit Enter sondern mit STRG+SHIFT+ENTER abschließen. Dann klappt es.

Da die Formel eine Array-Formel ist, durchläuft sie quasi die Zeilen 1 bis 12, gibt die Zeilennummer zurück und rechnet mit dieser, die Funktion aus. Außen herum ist ja SUMME(), so dass alle 12 Werte addiert werden. Und das mit 1 Formel!!!

Wenn Du noch Fragen hast, melde Dich! Wenn Du z.B. einen variablen Zähler 1..x brauchst...

Viel Spaß,
Andreas

nach oben   nach unten

Re: Summenfunktion
von: Robert Heusmann
Geschrieben am: 13.06.2002 - 13:46:30

You saved my day. Vielen Dank Andreas, es funktioniert!

Grüße

Robert


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Kleines Problem mit Button"