Wenn



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Wenn
von: Thomas
Geschrieben am: 25.06.2002 - 08:36:11

Liebes Forum!

Ich bräuchte wieder mal Hilfe.

In Spalte A und Spalte B steht ein Wert. In Spalte C bräuchte ich folgende Auskunft:

Wenn zb A1 um 1 größer als B1 dann 1 oder A1 um 1 kleiner als B1 dann 3.
Es bleibt aber nicht bei den 2 Bedingungen. Es werden ungefähr 6 - 8 verschiedene sein.

Bitte um Hilfe.

Liebe Grüße
Thomas

nach oben   nach unten

Re: Wenn
von: Alan Hathway
Geschrieben am: 25.06.2002 - 08:40:06

Das kannst Du mit WENN machen

Aber es können maximal nur 7 Wenns verschachtelt werden.

Wenn zb A1 um 1 größer als B1 dann 1 oder A1 um 1 kleiner als B1 dann 3:

=WENN(A1=B1+1;1;WENN(A1=B1-1;3;99))

Alan Hathway

nach oben   nach unten

Re: Wenn
von: Rainer K.
Geschrieben am: 25.06.2002 - 09:03:44

Hi !
Wenn mit mehr als 7 Bedingungen
schau mal unter excelformeln.de

Gruss

Rainer


nach oben   nach unten

Re: Wenn
von: Heinz
Geschrieben am: 25.06.2002 - 09:07:15

Hallo Thomas,

eine kleine Erweiterung von Alan´s Formel:

Mehr als 7 geschachtelte Wenn:

in der letzten Schachtelung ....;"")))) (""=leere Zelle). Dann weiter mit +Wenn(.....
also etwa so:

=wenn(.......;""))))+wenn(....

Oder versuchs mit Sverweis.

Gruß Heinz

nach oben   nach unten

Bist Du da sicher, Heinz?
von: Alan Hathway
Geschrieben am: 25.06.2002 - 09:35:01

Errrrrrrrr Hmmmmmmmmmmmm

Erstens nicht + sondern & Probier mal
=WENN(A1=1;99;"")+WENN(A1=2;88;"") ist falsch #WERT
=WENN(A1=1;99;"")&WENN(A1=2;88;"") ist richtig

Zweitens ist die Antwort dann eine Zeichenkette = linksbündig im Feld

D.h. das geht nur mit Zeichenketten gut oder?

Die Frage war aber eindeutig mit Zahlen versehen.

Und wie SVERWEIS für das konkrete Beispiel benutzt werden soll, ist mir auch unklar

Alan Hathway


nach oben   nach unten

Re: Bist Du da sicher, Heinz?
von: Heinz
Geschrieben am: 25.06.2002 - 10:51:17

Hallo Alan,

jeder macht mal einen Gedankenfehler. Du hast recht mein "" ist falsch es müsste 0 sin.

Aber + geht zum verknüpfen von mehr als 7 Wenn bei Zahlen

in A8 steht 2

=WENN(A8=1;99;0)+WENN(A8=2;88;0) liefert 88 als Zahl
=WENN(A8=1;99;"")&WENN(A8=2;88;"") liefert 88 als Text

Bei meiner Hinweis SVerweis ging ich davon aus, dass es immer die gleiche Zelle ist mit verschiedenen Werten und dann muss ein Sverweis doch gehen.

Nochmals danke für deinen Hinweis, zwei Gehirne denken eben mehr als eines.

Gruß Heinz


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Makro bei verlassen einer Zelle"