Auswertung von noten(dringend)



Excel-Version: Versionsunabhängig
nach unten

Betrifft: Auswertung von noten(dringend)
von: Markus
Geschrieben am: 01.07.2002 - 20:55:28

also ich habe drei Klausuren(je mit unterschiedlichen maximalpunktzahlen(120, 90 und 150 Punkte) und mehrere Studenten, bei denen je die erreichte punktzahl gegeben ist, nun soll automatisch berechnet werden welche note der schüler hat (nach dem schlüssel: <20%=6, <50%=5, <67%=4, <82%=3, <92%=2, bis100%=1)
und dann noch automatisch ob er bestanden hat, oder nicht (ab 4 ist bestanden) dann soll daraus ein Diagramm gemacht werden: aus dem ersichtlich ist, wieviele schüler welche note erreicht haben, und wieviele bestanden, bzw. Durchgefallen sind.

wie muss ich da vorgehen?

vielen vielen dank für hilfe, is wirklcih dringend

Markus

nach oben   nach unten

Re: Auswertung von noten(dringend)
von: Wolfgang
Geschrieben am: 01.07.2002 - 22:36:47

Versuchs mal mit der WENN Funktion
Die punkte in der entsprechenden spalte eintragen.
In der spalte daneben die prozente ausrechnen(Formartierung der Zellen in Prozent)
in der spalte daneben folgende WENN Funktion
=WENN(C2<20%;6;WENN(C2<50%;5;WENN(C2<67%;4;WENN(C2<82%;3;WENN(C2<92%;2;1)))))
und in der spate daneben
=WENN(D2<5;"Bestanden";"nicht Bestanden")
so sollte es funktionieren
viel spass beim ausprobieren
wolfgang

nach oben   nach unten

Re: Auswertung von noten(dringend)
von: Wolfgang
Geschrieben am: 01.07.2002 - 22:36:56

Versuchs mal mit der WENN Funktion
Die punkte in der entsprechenden spalte eintragen.
In der spalte daneben die prozente ausrechnen(Formartierung der Zellen in Prozent)
in der spalte daneben folgende WENN Funktion
=WENN(C2<20%;6;WENN(C2<50%;5;WENN(C2<67%;4;WENN(C2<82%;3;WENN(C2<92%;2;1)))))
und in der spate daneben
=WENN(D2<5;"Bestanden";"nicht Bestanden")
so sollte es funktionieren
viel spass beim ausprobieren
wolfgang

nach oben   nach unten

Re: Auswertung von noten(dringend)
von: Hans W. Hofmann
Geschrieben am: 01.07.2002 - 23:04:52

Hallo Markus,

hilft Dir das weiter:


Function Note(Schlüssel, Punkte As Integer, Komma As Boolean) As Single
Dim As Integer
' Schlüssel ist ein Array(0..6) mit
' Schlüssel(0)=maxPunkte 1.0
' Schlüssel(1)=Punkte Notengrenze 1.5, Schlüssel(2)=Punkte Notengrenze 2.5 ...
' Schlüssel(6)=Punkte Notengrenze 6.0
' Komma gibt an ob Nachkommastellen berechnet werden sollen oder nicht
' Beispiel: =Note({100.92.81.67.50.20.8};A1;WAHR)
a = LBound(Schlüssel)
If UBound(Schlüssel) - a < 6 Then Note = "#Schlüssel?": Exit Function
Select Case Punkte
 Case Is >= Schlüssel(a + 1)
    Note = 1# - Komma * (Schlüssel(a) - Punkte) / (Schlüssel(a) - Schlüssel(a + 1)) / 2
 Case Is >= Schlüssel(a + 2)
         Note = 1# - Komma * ((Schlüssel(a + 1) - Punkte) / (Schlüssel(a + 1) - Schlüssel(a + 2)) + 0.5)
 Case Is >= Schlüssel(a + 3)
         Note = 2# - Komma * ((Schlüssel(a + 2) - Punkte) / (Schlüssel(a + 2) - Schlüssel(a + 3)) + 0.5)
 Case Is >= Schlüssel(a + 4)
         Note = 3# - Komma * ((Schlüssel(a + 3) - Punkte) / (Schlüssel(a + 3) - Schlüssel(a + 4)) + 0.5)
 Case Is >= Schlüssel(a + 5)
         Note = 4# - Komma * ((Schlüssel(a + 4) - Punkte) / (Schlüssel(a + 4) - Schlüssel(a + 5)) + 0.5)
 Case Is > Schlüssel(a + 6)
         Note = 5# - Komma * ((Schlüssel(a + 5) - Punkte) / (Schlüssel(a + 5) - Schlüssel(a + 6)) / 2 + 0.5)
 Case Else
      Note = 6
End Select
End Function


Gruß HW
nach oben   nach unten

Re: Auswertung von noten(dringend)
von: axel.meyer
Geschrieben am: 01.07.2002 - 23:16:12

hi markus,

check mal deine mailbox, habe mir mal deine aufgabe als studienobjekt angetan und was nettes erarbeitet.

gruß, axel


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Auswertung von noten(dringend)"