Zeilen zählen



Excel-Version: 5.0/7.0
nach unten

Betrifft: Zeilen zählen
von: teute
Geschrieben am: 11.07.2002 - 10:03:00

Hallo zusammen,
wer kann mir helfen..ich will die anzahl der zeilen wissen, die gefüllt sind. das problem dabei ist, das sich auf 10.000 Zeilen
verknüpfungen beziehen ich aber nur die auslesen bzw. zählen möchte, die auch mit werten/daten gefüllt sind.

danke.

m.t.


nach oben   nach unten

{=SUMME(WENN(A1:A100="";0;1))}
von: Daniel Ov
Geschrieben am: 11.07.2002 - 11:13:37

Hallo Teute,

für meinen Lösungsvorschlag müßte als Erkennungszeichen die Verknüpfung/Formel bei ungefülltem Zustand eine leere Zeichenkette zurück gegeben wird; also "".
Im Beispiel gehe ich jetzt nur von der Auswertung der Spalte A aus.

in eine freie Zelle (nicht in Spalte A)
Auswertung der Zeilen 1 bis 100 in Spalte A
{=SUMME(WENN(A1:A100<>"";1;0))} oder aus Betreffzeile
die geschweiften Klammer nicht eingeben; sie werden automatisch erzeugt wenn die Zelle mit Strg+Shift+Enter abgeschlossen wird.

Viel Erfolg
Daniel Ov

nach oben   nach unten

Re: {=SUMME(WENN(A1:A100="";0;1))}
von: teute
Geschrieben am: 11.07.2002 - 11:27:01

Hallo Daniel,

danke das funktioniert gut...aber wie sieht hierzu der vba-code
aus??? wenn ich die Anzahl per Makro auslesen möchte ohne die Excel-Funktion im Tabellenblatt zu implementieren.

Danke.

teute


nach oben   nach unten

Re: {=SUMME(WENN(A1:A100="";0;1))}
von: Daniel Ov
Geschrieben am: 12.07.2002 - 10:02:56

Hallo Teute,

in einer Schleife (läuft von A1 bis A16000; oder so wie du es brauchst)

If Zellwert.aktivezelle = "" dann keine Daten sonst zeilenzähler=zeilenzähler+1
aktivezelle um eine Zeile nach unten verschieben


Viele Grüße
Daniel


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Zeilen zählen"