Microsoft Excel

Herbers Excel/VBA-Archiv

leeree Zellen erkennen

Betrifft: leeree Zellen erkennen von: Fedorin
Geschrieben am: 06.02.2014 07:51:17

Guten Morgen,aauch wenn' noch etwas wolkig aussieht!
Habe ein vermutlch lächerliches Problem:
Wenn in Zelle a1 nichts steht, dann soll auch in c1 nicht stehen, wenn doch, dann ein Wert aus d3
Die Formel die ich eingesetzt habe war also: wenn(a1="";"";d3)
Problem: a1 ist nie "ganz leer", denn ihr Inhalt bezieht sich auf eine andere Zelle, nämlich g1 (Eiintrag in a1 lautet also =g1) Dieses g1 scheint schon als Inhalt gewertet zu werden.
Hat jemand eine Idee, wie ich das fettgedruckte Ziel doch erreichen kann?
Im Voraus schohn mal herzlichen Dank für eure Mühe
Fedorin

  

Betrifft: AW: leeree Zellen erkennen von: KlausF
Geschrieben am: 06.02.2014 08:20:09

Moin,
und warum fragst du denn nicht gleich g1 ab?
wenn(g1="";"";d3)

Gruß
Klaus


  

Betrifft: AW: leeree Zellen erkennen von: Klaus M.vdT.
Geschrieben am: 06.02.2014 08:36:15

Hallo Fedorin,

Möglichkeit 1:
=wenn(a1=0;"";d3)
Grund: Wenn G1 leer ist, referenziert =G1 nicht auf "", sondern auf 0. Kannst du aber auch in der Zelle sehen ....

Oder gleich aus A1 korrekt auf G1 referenzieren und ISTLEER prüfen:
A1: =WENN(ISTLEER(G1);"";G1)
C1: =WENN(A1="";"";D3)

Oder halt direkt G1 abfragen, wie mein Namensvetter vorschlug

Grüße,
Klaus M.vdT.


  

Betrifft: AW: leeree Zellen erkennen von: Fedorin
Geschrieben am: 06.02.2014 12:01:14

Hallo,
danke für eure Hilfe, der Hinweis, auf 0 statt auf "" zu prüfen brachte die Lösung, direktes Abfragen von g1 ging nicht, da die tatsächliche Arbeitsmappe etwas anders aufgebaut ist, als in meiner Schilderung beschrieben (ich wollte es halt nicht zu kompliziert machen)
nochmals vielen Dank
Fedorin


  

Betrifft: Danke für die Rückmeldung! owT. von: Klaus M.vdT.
Geschrieben am: 06.02.2014 12:22:52

.


 

Beiträge aus den Excel-Beispielen zum Thema "leeree Zellen erkennen"