Microsoft Excel

Herbers Excel/VBA-Archiv

Summewenn

Betrifft: Summewenn von: Peter
Geschrieben am: 25.04.2014 13:19:30

Hallo,

ich habe ein Problem in der angefügten Tabelle.
https://www.herber.de/bbs/user/90346.xlsx

Im Tabellenblatt Liste sind alle Bestellungen von Kunden aufgelistet.

Im Tabellenblatt Stichtag möchte ich sehen, ob ein Kunde zu einem bestimmten Datum eine Bestellung im System hat.

Das kann ich mir mit einer Wenn(Sverweis...) Formel zurecht basteln. Allerdings nur unter der Bedingung, dass die Liste eine Mehrfachsortierung nach Knr aufsteigend und dann nach Datum absteigend aufweist. Vergesse ich zu sortieren, fliegt mir das Ganze um die Ohren.

Da dachte ich mir, das SUMMENPRODUKT() der richtige Ansatz ist, aber leider beisse ich mir daran die Zähne aus. Hat jemand einen Tipp, wie ich das umsetzen kann?

Gruß,
Peter

PS: Es handelt sich um ein stark vereinfachtes Beispiel. Ausser den gestellten Forderungen an das Problem ist nichts weiter zu beachten. Auch Alternativen wie Autofilter etc. sind nicht von Belang :-)

  

Betrifft: ? falsche Datei angehängt ? von: Arthur
Geschrieben am: 25.04.2014 14:13:55

Hallo Peter.

Hast du eine falsche Datei angehängt? Es ist weder eine Tabelle 'Liste', noch eine namens 'Stichtag' zu finden.

Gruß, Arthur


  

Betrifft: Hier die richtige Datei von: Peter
Geschrieben am: 25.04.2014 14:20:50

Ups...hier ist die richtige Datei

https://www.herber.de/bbs/user/90347.xlsx


  

Betrifft: AW: Hier die richtige Datei von: Christian
Geschrieben am: 25.04.2014 14:31:44

Hallo Peter,

=WENN(SUMMENPRODUKT((Liste!$B$2:$B$1000=B4)*(Liste!$C$2:$C$1000=$A$1))>0;"ja";"nein")

MfG Christian


  

Betrifft: AW: Summewenn von: Christian
Geschrieben am: 25.04.2014 14:23:47

Hallo Peter,

etwas konfus, da in der Datei weder das Tabellenblatt Liste noch das Tabellenblatt Stichtag enthalten ist!?!

MfG Christian


  

Betrifft: AW: Summewenn von: Peter
Geschrieben am: 25.04.2014 14:57:06

Stimmt, aber ich habe die richtige Datei mittlerweile hochgeladen.


 

Beiträge aus den Excel-Beispielen zum Thema "Summewenn"