Microsoft Excel

Herbers Excel/VBA-Archiv

Formel gesucht

Betrifft: Formel gesucht von: Jean Gitanes
Geschrieben am: 28.06.2014 16:30:58

Hallo,

in Spalte A sind Artikelnr von Verkäufen gespeichert, mehrere 100.
In B1, B2 und B3 werden 3 verschiedene Artikelnr eingegeben, zB 4711, 8888, 7456.

Wie lautet die Formel, die die Anzahl der Verkäufe mit diesen 3 Artikelnr ermittelt?
Mit Zählenwenn wird einfach kein korrektes Ergebnis angezeigt.

Besten Dank im voraus.

Gruß
Jean

  

Betrifft: AW: Formel gesucht von: Hajo_Zi
Geschrieben am: 28.06.2014 16:35:04

Hallo Jean,

benutze Summenprodukt()

Ich baue keine Datei nach, die Zeit hat schon jemand investiert.
Ein Nachbau sieht bestimmt anders aus als das Original.
Ein Link zur Datei wäre nicht schlecht.
Von unsicheren Servern wie z.B. www.file-upload.net lade ich keine Datei runter. (lt. Einschätzung meines Virenprogramms)
Der Dateiname sollte was mit dem Problem zu tun haben.
Ich habe mir z.B. einen Ordner angelegt in dem ich alle Dateien aus dem Internet speichere. Bei Dateinamen wie Test..., Mappe…, Beispiel… wird eine vorhandene überschrieben.
Ein Bild in Excel geöffnet sieht anders aus als das Bild.

Gruß Hajo


  

Betrifft: AW: Formel gesucht von: Jean Gitanes
Geschrieben am: 28.06.2014 17:40:28

Hallo Hajo,

vielen Dank für Deinen Beitrag.
Folgende Formel funktioniert leider nicht
=ZÄHLENWENNS(A16:A220;{4711;8888;3434})

Als Ergebnis wird der Wert 1 angezeigt, obwohl die Werte 4711, 8888, 3434 mehrfach vorkommen.
Im konkreten Fall müsste der Wert 38 angezeigt werden.

Was ist an der Formel falsch?

Gruß
Jean


  

Betrifft: AW: Formel gesucht von: Hajo_Zi
Geschrieben am: 28.06.2014 17:41:53

das mag wohl daran liegen das Du ; statt . geschrieben hast.

Gruß Hajo


  

Betrifft: Mit Punkt ist das Ergebnis auch 1 von: Jean Gitanes
Geschrieben am: 28.06.2014 17:48:01

Hallo Hajo,

der Tausch von ; zu . bringt nicht das gewünschte Ergebnis, leider.
=ZÄHLENWENN(A16:A220;{4711.8888.3434})
Vielleicht gibt es doch noch eine Lösung.
Danke für Deine Hilfe.

Gruß
Jean


  

Betrifft: AW: Mit Punkt ist das Ergebnis auch 1 von: Jean Gitanes
Geschrieben am: 28.06.2014 17:59:12

Hallo Hajo,

so wird das richtige Ergebnis angezeigt:
=SUMMENPRODUKT((A16:A22=B16)+(A16:A22=B17)+(A16:A22=B18)*1),
aber das ist ganz schön umständlich, wenn die Liste der gesuchten Artikelnummern länger wird.

Na ja, sind wir mal optimistisch. Vielleicht ist noch eine bessere Lösung zu lesen ...

Gruß
Jean


  

Betrifft: AW: Formel gesucht von: Josef B
Geschrieben am: 28.06.2014 21:30:16

Hallo Jean

Du bist schon sehr nahe dran.
Einfach nur ZÄHLENWENN ohne "s", und weil dein Array mit drei Bedingungen auch drei Werte ergibt, musst du diese drei Werte mit Hilfe der Funktion SUMME zusammenfassen.
=SUMME(ZÄHLENWENN(A16:A220;{4711;8888;3434}))

Gruss Sepp


  

Betrifft: AW: Formel gesucht von: WalterK
Geschrieben am: 28.06.2014 22:03:25

Hallo Sepp,

weil mich die Lösung auch beschäftigt möchte ich mich hier kurz einschalten:

Jean sucht eine Formel die auch funktioniert wenn sich die Suchbegriffe erweitern:
Zitat: aber das ist ganz schön umständlich, wenn die Liste der gesuchten Artikelnummern länger wird.

Gibt es dafür auch eine Lösung ohne die einzelnen Suchbegriffe eingeben zu müssen?

Danke und Servus, Walter


  

Betrifft: Zählen mit mehreren Kriterien von: Josef B
Geschrieben am: 29.06.2014 09:28:07

Hallo Walter

Natürlich kann man die Zähl-Bedingungen auch aus einem Tabellenbereich auslesen.

Zum Beispiel so:
=SUMMENPRODUKT(ZÄHLENWENN(A16:A28;B16:B20))

Das geht auch mit der Funktion SUMME(), nur muss man diese dann als Array-Formel abschliessen.

Gruss Sepp


  

Betrifft: Perfekt, Danke Sepp. Servus, Walter von: WalterK
Geschrieben am: 29.06.2014 09:48:09




  

Betrifft: Danke - genau dies habe ich gesucht von: Jean Gitanes
Geschrieben am: 29.06.2014 11:17:25

Guten Tag, Sepp,

genau diese Lösung habe ich gesucht. Vielen Dank für Deine Unterstützung.
Einen schönen Sonntag.

Gruß
Jean


 

Beiträge aus den Excel-Beispielen zum Thema "Formel gesucht"