Bekomme Funktion nicht hin...



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Bekomme Funktion nicht hin...
von: Marc hat ne Frage
Geschrieben am: 16.07.2002 - 15:11:56

Habe folgendes Problem:

Habe eine Tabelle, die folgendermaßen aufgebaut ist:

Datum, A, B.

Datum ist ja klar, unter A bzw. B stehen mehrstellige Codes (pro Tag nur in einem Feld!). Ich möchte jetzt an einem bestimmten Tag sehen, ob in einem der beiden (nur in einem,z.B. A) etwas steht! Die Funktion soll mir dann eine 1 ausgeben! Weiteres Problem ist, dass in der Spalte Datum oft mehrfach dasselbe Datum vertreten ist, sodass z.B. bei 8 x 01.01.02 und 5 x Eintrag in Spalte A ein Ergebnis: 5 herauskommen muss!!! (weil er alle gleichen Datums (schlechtes Deutsch ;) durchsuchen soll und mir aber nur angeben soll, in wievielen Zellen der Spalte A ein Eintrag ist!

So, ich saß jetzt einen ganzen Tag davor und hab keinen Peil mehr! HILFE!!!!!!!!!!! Mit VB kann ich leider nicht gut umgehen...

Für ne Antwort wär ich sehr dankbar!!!!!!!!!!!!!!

THX

nach oben   nach unten

Re: Bekomme Funktion nicht hin...
von: andreas e
Geschrieben am: 16.07.2002 - 15:14:28

hallo,

etwas verwirrend ! Poste mal den Tabellenaufbau dann sieht man vielleicht mehr

gruß
andreas e

http://www.skripteundaufgaben.de viele kostenlose Downloads und Links zu EXCEL und mehr

nach oben   nach unten

Re: Bekomme Funktion nicht hin...
von: Sorry! Hier der Tabellenaufbau...
Geschrieben am: 16.07.2002 - 16:03:09

Bin wohl zu blöd, ne tabelle als tabelle zu posten... Vielleicht verstehst Du es ja aber auch so! Daneben muss auf jeden Fall ne Spalte, die mir sagt, wieviel Rappold am 17.09.01 (z.B.) - wobei die 750 etc unwichtig sind und nur dafür da sind, um zu schauen, dass dort 1 Scheibe gebraucht wurde!

Datum Rappold Tyrolit
17.09.01 750 (das steht unter Rappold)
12.11.01 725 (unter Rappold)
17.09.01 715 (unter Rappold)
17.09.01 815 (unter Rappold)
17.09.01 777 (unter Tyrolit)
06.06.02 650 (unter Tyrolit)
07.06.02 758 (unter Rappold)
08.06.02 857 (unter Tyrolit)
09.06.02 444 (unter Rappold)




nach oben   nach unten

Re: Bekomme Funktion nicht hin...
von: andreas e
Geschrieben am: 16.07.2002 - 18:41:30

sorry aber ganz verstehe ich das nicht - sitze wahrscheinlich auf der leitung !
aber ich weiss echt nicht was bei dir wo berechnet werden soll

gruß
andreas e

http://www.skripteundaufgaben.de viele kostenlose Downloads und Links zu EXCEL und mehr

nach oben   nach unten

Re: Bekomme Funktion nicht hin...
von: Hm....
Geschrieben am: 16.07.2002 - 19:06:56

Oder ich kann mich nicht ausdrücken ;) Es geht nicht ums Berechnen - mehr ums Zählen! Nochmal:
1. jede Zahl in der Spalte Rappold bzw. Tyrolit steht für eine 1
2. dem 17.9. ist 3 x Rappolt und 1 Tyrolit zugeordnet
3. eine Formel soll mir nun in einer anderen Spalte anzeigen, wie oft Rappolt am z.B. 17.9. vorkommt.

Die Formel muss also die Spalte Datum nach dem 17.9. durchsuchen, wenn gefunden in der zeile gucken, ob bei Rappold oder Tyrolit etwas steht. Steht was bei Rappold, soll eine 1 ausgegeben werden - am Ende muss auf jeden fall als Summe irgendwie 3 stehen! Sonst mail mir mal, dann kann ich Dir die richtige Tab zusenden?!?!?!

Danke für Deine Mühe :)

Marc

nach oben   nach unten

Re: Bekomme Funktion nicht hin...
von: andreas e
Geschrieben am: 16.07.2002 - 19:26:02

Hallo,

so jetzt habe ichs glaube ich verstanden -

sieh dir das mal an :
Die Formel habe ich von der Seite www.excelformeln.de etwas abgewandelt

MS Excel von andreas e an andreas e
 ABCD
1DatumRappoldTyrolitgesuchtes_Datum
217.09.01750  17.09.01
312.11.01725  Rappold
417.09.01715  3
517.09.01815  {=SUMME(WENN((A1:A100=$D$2)*(B1:B100<>"");1))}
617.09.01  777Tyrolit
706.06.02  6501
807.06.02758  =SUMME(WENN((A1:A100=$D$2)*(C1:C100<>"");1))
908.06.02  857
1009.06.02444 
11   
12ACHTUNG!!!_Die_geschweiften_Klammern_vor_und_nach_derFormel_nicht!!!   
13eingeben_sondern_über_STRG-SHIFT-Enter_erzeugen   


gruß
andreas e

nach oben   nach unten

Re: Bekomme Funktion nicht hin...
von: Unglaublich!
Geschrieben am: 16.07.2002 - 19:29:16

Werde das nachher mal probieren! Sieht aber sehr gut aus!!!! Besten DANK!!!

Gruß, Marc


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Bekomme Funktion nicht hin..."