klassische Uhrzeitsaldierung



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: klassische Uhrzeitsaldierung
von: Helmut
Geschrieben am: 16.07.2002 - 22:54:37

Unsere Arbeitszeitermittlung mit SAP ist ausgefallen, so dass ich mir vorübergehend eine Excellösung erstellen will. Also die klassische "kommen/gehen-Saldierung". Die Darstellung der negativen Stunden macht trotz nachfolgender benutzerdefinierter Formatierung Probleme (Lattenzaun!):
[h]:mm;[Rot]-[h]:mm;0":"00;@
Was mache ich falsch?
nach oben   nach unten

Re: klassische Uhrzeitsaldierung
von: Friedel
Geschrieben am: 16.07.2002 - 23:10:35

Hallo Helmut,
Excel kennt keine negativen Zeiten - deswegen der Lattenzaun.
Als Lösung bietet sich an, die negativen Zeiten als Text darzustellen: =WENN(A2-A1<0;"-"&TEXT(ABS(A2-A1);"-[h]:mm");A2-A1)
Dies hat allerdings den Nachteil, das mit dem Ergebnis nicht weiter gerechnet werden kann. Sollte dies aber notwendig sein, dann empfiehlt es sich, die Uhrzeiten in Dezimalzahlen umzuwandeln.
Dazu muß lediglich die Uhrzeit mit "24" multipliziert werden und das Zellformat auf Zahl eingestellt sein (besser gesagt NICHT auf Uhrzeit). Aus "8:30" wird dann "8,5"

Viele Grüße aus Bruchköbel

Friedel

nach oben   nach unten

Re: klassische Uhrzeitsaldierung
von: Helmut
Geschrieben am: 17.07.2002 - 00:03:59

Hallo Friedel,
von Teil 1 der Antwort bin ich schon mal begeistert. Nur Teil 2 bekomme ich nicht umgesetzt. Die positiven Guthabenstd. lassen sich ja problemlos in Dezimalzahlen umwandeln. Aus 0:44 Std. werden 0,03 Std. usw. Aber der zum Text gewordene Negativsaldo von z.B. -0:19 Std. läßt sich doch nicht in eine Dezimalzahl verwandeln (#Wert!) !?
Übrigens... wo liegt denn Bruchköbel ?
nach oben   nach unten

Re: klassische Uhrzeitsaldierung
von: Hajo_Zi
Geschrieben am: 17.07.2002 - 06:18:12

Hallo Helmut

negative Uhrzeit kann in Excel nur dargestellt werden, wenn unter Extra, Optionen die Datumswerte 1904 aktiviert werden. Bitte Beachte alle bis zur Umstellung eingegebenen Werte werden umgerechnet.

Gruß Hajo


nach oben   nach unten

Re: klassische Uhrzeitsaldierung
von: Helmut
Geschrieben am: 17.07.2002 - 07:30:05

Guten Morgen Hajo,

genial und simpel zugleich. Man muss es halt nur wissen oder darauf kommen. Vielen Dank.
Gruß Helmut


nach oben   nach unten

Re: klassische Uhrzeitsaldierung
von: Friedel
Geschrieben am: 17.07.2002 - 09:42:34

Guten Morgen Helmut,

die zum Text gewandelten negativen Zeiten kannst du natürlich nicht umwandeln. Du mußt dann schon, ggf. in einer anderen Zelle, die Formel (z.B. in C1 "=(A1-B1)*24") einsetzen.
A1 - B1 = C1
08:00 - 09:00 = - 1,00


Ja, und Bruchköbel liegt ziemlich in der Mitte Deutschlands - ca. 25 km östlich von Frankfurt/Main, bei Hanau

Friedel


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Dateneinlese automatisch"