Microsoft Excel

Herbers Excel/VBA-Archiv

#wert

Betrifft: #wert von: Gerhard
Geschrieben am: 27.07.2014 08:36:29

Hallo zusammen,

ich habe ein Datum im Textformat mit =Datwert(Teil ..... umgewandelt.
Bei leeren Zellen wird #wert zurückgegeben.
Ich habe versucht, "#wert" mittels "Istfehler....." zu unterdrücken,
funktioniert aber nicht.

Wie kriege ich ein leeres Feld, wenn die Funktion #wert zurückgibt?

Danke im Voraus.
Gruss
Gerhard

  

Betrifft: AW: #wert von: Spenski
Geschrieben am: 27.07.2014 08:39:52

=wennfehler(deine Formel;"")

gruss


  

Betrifft: AW: #wert von: Hajo_Zi
Geschrieben am: 27.07.2014 10:04:05

es geht selbstverständlich auch mit Istfehler. Wennfehler() gibt es erst ab 2007.

Tabelle1

 CD
26 '01.01.14
27  
28 01.01.14

verwendete Formeln
Zelle Formel Bereich N/A
C28: D28=WENN(ISTFEHLER(DATWERT(C26));"";DATWERT(C26))  

Zahlenformate
Zelle Format Wert
C26 '@  
C28 'TT.MM.JJ;@  
D26 '@ 01.01.14
D28 'TT.MM.JJ;@ 41640
Zellen mit Format Standard werden nicht dargestellt
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.09 einschl. 64 Bit


GrußformelHomepage


  

Betrifft: AW: #wert von: Spenski
Geschrieben am: 27.07.2014 10:41:34

oder so :)


gruss


  

Betrifft: AW: #wert von: Gerhard
Geschrieben am: 27.07.2014 11:51:38

Hallo zusammen,

ich habe die Formel "Wenn(IstFehler.... verwendet,
allerdings verweist der Cursor immer auf ;"";
(die Platzhalter für leer),
irgendetwas nimmt er nicht,
ich habe es auch mit "0" versucht,
funktioniert ebenfalls nicht.

Grüsse
Gerhard


  

Betrifft: AW: #wert von: Spenski
Geschrieben am: 27.07.2014 12:09:43

zeig doch mal die ganze formel


  

Betrifft: AW: #wert von: Gerhard
Geschrieben am: 27.07.2014 13:44:43

Hallo,

meine Formel sieht wie folgt aus:
=wenn(IstFehler(DATWERT(Teil(CD3;7;2)&"."&Teil(CD3;5;2)&"."&Teil3;1;4));"";(DATWERT(Teil(CD3;7;2) &"."&Teil(CD3;5;2)&"."&Teil3;1;4))

Ich finde den Fehler nicht.
Danke im voraus.

Gruss
Gerhard


  

Betrifft: AW: #wert von: Spenski
Geschrieben am: 27.07.2014 13:52:58

=WENN(ISTFEHLER(DATWERT(TEIL(CD3;7;2)&"."&TEIL(CD3;5;2)&"."&TEIL(CD3;1;4)));""; DATWERT(TEIL(CD3;7;2)&"."&TEIL(CD3;5;2)&"."&TEIL(CD3;1;4)))

vor dem ;""; muss noch eine klammer

und der fettmarkierte bereich fehlte , aber das kamm wohl vom abtippen??


  

Betrifft: AW: #wert von: Gerhard
Geschrieben am: 27.07.2014 14:10:42

Danke.
Super.Jetzt klappts.

(CD war ein Abtippfehler).

Gruss
Gerhard


  

Betrifft: AW: #wert von: Spenski
Geschrieben am: 27.07.2014 14:19:36

ansonsten gibts halt noch die möglichkeit

=WENNFEHLER(DATWERT(TEIL(CD3;7;2)&"."&TEIL(CD3;5;2)&"."&TEIL(CD3;1;4));"")

wie hajo schon sagte ab 2007 gültig


  

Betrifft: AW: #wert von: Hajo_Zi
Geschrieben am: 27.07.2014 12:42:55

Hallo Gerhard,

wie Du in meinem Beitrag siehst geht es. Deine Tabelle sehe ich nicht.

Gruß Hajo