Microsoft Excel

Herbers Excel/VBA-Archiv

Summenaddition

Betrifft: Summenaddition von: Karl
Geschrieben am: 01.08.2014 08:20:25

Guten Morgen, liebe Forumsteilnehmer,
ich benötige eine Additionsformel, welche die Werte folgendermaßen addiert:

Die Werte der Spalte B sollen nur bis 8€ addiert werden; das Ergebnis soll in B7 stehen;
eine weitere Addition soll den Rest addieren, d.h. nur die Werte, die größer als 8€ sind, also ab 9€ bis X; das Ergebnis benötige ich in B8
B7 hat somit als Ergebnis die Summe 26€
B8 hat als Summe 4€ (B2 + B3)
Spalte A Spalte B

A 10,00 €
B 10,00 €
C 8,00 €
D 2,00 €
E
Summe:
Summe:
Im Voraus schon mal vielen Dank
Karl

  

Betrifft: AW: Summenaddition von: Hajo_Zi
Geschrieben am: 01.08.2014 08:25:37

Hallo Karl,


Tabelle2

 ABC
1108Summe 8
21022Summe Rest
38  
42  

verwendete Formeln
Zelle Formel Bereich N/A
B1=SUMMEWENN($A$1:$A$4;8;$A$1:$A$4)  
B2=SUMMEWENN($A$1:$A$4;"<>" &8;$A$1:$A$4)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.11 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: Summenaddition von: Karl
Geschrieben am: 01.08.2014 08:37:45

Das funktioniert noch nicht.
Die Werte dürfen nur bis zu einer Höhe von 8 addiert werden.
Die 2. Addition addiert erst Werte ab 8.
Das Ergebnis muss 26 und 4 sein.


  

Betrifft: bei Dir ist 10+10+8= 26 ? ... von: neopa C (paneo)
Geschrieben am: 01.08.2014 08:30:44

Hallo Karl,

... zumindest das ist erklärungsbedürftig und dann auch noch was steht in B2:B3 ...

Ansonsten:

=SUMMEWENN(B:B;">=8";B:B)

Gruß Werner
.. , - ...Hallo Karl,

... zumindest das ist erklärungsbedürftig und dann auch noch was steht in B2:B3 ...

Ansonsten:
=SUMMEWENN(B:B;">=8";B:B)

Gruß Werner
.. , - ...


  

Betrifft: AW: bei Dir ist 10+10+8= 26 ? ... von: Karl
Geschrieben am: 01.08.2014 08:34:10

Die Addition sieht folgendermaßen aus:
10 (hier nur bis 8)
10 (hier nur bis 8)
8 ( 8 )
2 ( 2 )
Summe = 26

Und jetzt noch der Rest ab 8 bis Unendlich:
als bei 10 ( 2 )
bei 10 ( 2 )


  

Betrifft: jetzt ist es klarer ... von: neopa C (paneo)
Geschrieben am: 01.08.2014 08:48:08

Hallo Karl,

... dann z.B. so:

 BCDE
1    
210  26
310  4
48   
52   
6    

Formeln der Tabelle
ZelleFormel
E2=SUMMENPRODUKT((B2:B99>8)*8+(B2:B99<=8)*B2:B99)
E3=SUMMENPRODUKT((B2:B99>8)*(B2:B99-8))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: AW: jetzt ist es klarer ... von: Karl
Geschrieben am: 06.08.2014 09:55:08

Hallo Werner,

diese Antwort ging in meinem Mail-Ordner unter.
Danke nochmals und eine schöne Zeit
Gruß
Karl


  

Betrifft: Teiladdition von: Erich G.
Geschrieben am: 01.08.2014 08:50:08

Hi Karl,
meine Vermutung:

 ABCD
110 bis 826
210 über 84
38   
42   

Formeln der Tabelle
ZelleFormel
D1{=SUMME(WENN(A$1:A$4>8;8;A$1:A$4))}
D2{=SUMME(WENN(A$1:A$4>8;A$1:A$4-8))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Teiladdition von: Karl
Geschrieben am: 01.08.2014 08:55:40

Lieber Erich,

danke für die Lösung in Zelle D. Ist eigentlich eine einfache Formel, aber ich habe sie nicht rausbekommen.
Schönes Wochenende
Gruß
Karl