Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMENPRODUKT

Betrifft: SUMMENPRODUKT von: Manfred
Geschrieben am: 06.08.2014 12:09:45

Hallo zusammen,

ist es möglich mit der Formel =SUMMENPRODUKT((MONAT($AC$4:$OD$4)=8)*$AC10:$OD10)
Zellen mit 4v oder 10v nur die Werte zu summieren ? Ergebnis wäre 14.

Weis hier jemand eine Lösung ? Ich habe im Forum nichts gefunden.

Mit freundlichen Grüßen
Manfred

  

Betrifft: AW: SUMMENPRODUKT Rückfrage von: Daniel
Geschrieben am: 06.08.2014 12:15:36

ist das "v" auch eine Bedingung?
soll auch ein Wert wie "10x" oder 10 mit summiert werden, sollte der Monat zutreffen?
welche Werte können noch im Zellbereich vorkommen (zb. reine Text)?
Gruß Daniel


  

Betrifft: AW: SUMMENPRODUKT Rückfrage von: Manfred
Geschrieben am: 06.08.2014 12:22:12

Hallo Daniel,

es kommen nur Zahlen wie 1, 2 usw. und Werte 1v, 2v, usw. vor. Keine anderen Werte wie 1x, 2x usw.

Ich benötige das für bestimmte Mitarbeiter die ihre Werte dann mit 1v, 2v, 3v usw. eingeben müssen.

Gruß
Manfred


  

Betrifft: AW: SUMMENPRODUKT Rückfrage von: Daniel
Geschrieben am: 06.08.2014 12:57:58

Hi

probiers mal so:
a) nur die Werte mit v am ende:

=SUMME(WENN(MONAT($AC$4:$AL$4)=8;WENN(RECHTS($AC10:$AL10;1)="v";WERT(WECHSELN($AC10:$AL10;"v";""))))) 

b) alle Werte summieren:
=SUMME(WENN(MONAT($AC$4:$AL$4)=8;WENN(RECHTS($AC10:$AL10;1)<>"";WERT(WECHSELN($AC10:$AL10;"v";""))))) 
beide Formeln sind Matrixformeln, dh Eingabe immer mit STRG+SHIFT+ENTER abschließen

Gruß Daniel


  

Betrifft: AW: SUMMENPRODUKT Rückfrage von: Manfred
Geschrieben am: 06.08.2014 15:05:44

Hallo Daniel,

recht herzlichen Dank für deine Antwort.

Formel 1 funzt suppi. Geht das auch ohne Matrixformel ? Ich muß hier laufend ändern und über 50 Zeilen und 25 Spalten berücksichtigen.

Kannst du mir die 2te Formel so umbauen das nur ganze Zahlen (1, 2, usw.) summiert werden, nicht aber 1v, 2v, die sollen nicht berücksichtigt werden.

Gruß
Manfred


  

Betrifft: AW: SUMMENPRODUKT von: Hajo_Zi
Geschrieben am: 06.08.2014 12:20:51

Hallo Manfred,

=SUMMENPRODUKT((MONAT($AC$4:$OD$4)=8)*(($AC$6:$OD$6="4v")+($AC$6:$OD$6="10v"))*$AC10:$OD10)

GrußformelHomepage


  

Betrifft: AW: SUMMENPRODUKT von: Manfred
Geschrieben am: 06.08.2014 12:26:21

Hallo Hajo,

vielen Dank für die Antwort. Die Werte sind individuell, sie liegen zwischen 1v bis 12v.

Entschuldigung wenn ich mich falsch ausgedrückt habe.

Gruß
Manfred


  

Betrifft: AW: SUMMENPRODUKT von: Hajo_Zi
Geschrieben am: 06.08.2014 12:32:11

Hallo Manfred,

wer hindert Dich dran die fehlenden noch einzutragen?

Gruß Hajo


  

Betrifft: AW: SUMMENPRODUKT von: Manfred
Geschrieben am: 06.08.2014 12:37:33

Hallo Hajo,

ja du hast mal wieder recht, werde die Formel erweitern.

Gruß
Manfred


  

Betrifft: AW: SUMMENPRODUKT von: Johann
Geschrieben am: 06.08.2014 12:20:57

Hallo Manfred,

versuche folgendes: ~f~=SUMMENPRODUKT((MONAT($AC$4:$OD$4)=8)*Links($AC10:$OD10;1))

Gruß Johann


  

Betrifft: nachgefragt ... von: neopa C (paneo)
Geschrieben am: 06.08.2014 12:31:44

Hallo Manfred,

... bezieht sich Deine Anfrage auf Daten gemäß Deinem Thread hier https://www.herber.de/forum/messages/1374244.htmlß

Wenn ja muss in der dortigen Formel nur die Bedingungsabgleich mit dem Monat noch erweitert werden.


Gruß Werner
.. , - ...


  

Betrifft: AW: korrekter Link von: Hajo_Zi
Geschrieben am: 06.08.2014 12:42:03

https://www.herber.de/forum/messages/1374244.html


  

Betrifft: Danke Hajo owT von: neopa C (paneo)
Geschrieben am: 06.08.2014 13:00:14

Gruß Werner
.. , - ...


  

Betrifft: AW: Danke Hajo owT von: Manfred
Geschrieben am: 06.08.2014 15:07:37

Hallo Werner,

ich benötige mehrere aber verschiedene Formeln zu diesem Thema.

Gruß
Manfred