Microsoft Excel

Herbers Excel/VBA-Archiv

Formel Preisverlauf

Betrifft: Formel Preisverlauf von: Christian
Geschrieben am: 11.08.2014 15:24:27

Hallo,

ich brauch mal wieder eure Können :)

Ich hab für verschiedene Mengen einen Preis und jetzt möchte ich aber das ich in einer Zelle eine beliebige Menge eingeben kann und mir dazu (evtl. über eine Formel) der Preis dazu angeben wird. Jetzt habe ich das über die Formel dargestellt die es mir im Diagramm als Trendline anzeigt aber diese ist leider sehr ungenau. Könnt Ihr mir da weiter Helfen?

Hab ein Beispiel wie ich es jetzt habe mal mit angehängt

https://www.herber.de/bbs/user/92022.xlsx

Vielen Dank schon einmal

  

Betrifft: AW: Formel Preisverlauf von: fcs
Geschrieben am: 11.08.2014 16:30:15

Hallo Christian,

der Kurvenverlauf äßt sich durch keine der Trendlinien vernünftig annähern.

Alternative:
Lineare Interpolation zwishen den vorgegebenen Werten- Formel in D14:

=WENN(C14<500;D4;WENN(C14>=C11;D11;INDEX($D$4:$D$11;VERGLEICH(C14;$C$4:$C$11;1)) 
+(C14-INDEX($C$4:$C$11;VERGLEICH(C14;$C$4:$C$11;1)))/ 
(INDEX($C$4:$C$11;VERGLEICH(C14;$C$4:$C$11;1)+1) 
-INDEX($C$4:$C$11;VERGLEICH(C14;$C$4:$C$11;1)))* 
(INDEX($D$4:$D$11;VERGLEICH(C14;$C$4:$C$11;1)+1)-
INDEX($D$4:$D$11;VERGLEICH(C14;$C$4:$C$11;1)))))
Ansonsten könnte man natürlich abschnittsweise Kurven aus jeweils 3 oder 4 Punkten berechnen.
Dies wird dann aber beliebig aufwendig.

Gruß
Franz


  

Betrifft: AW: Formel Preisverlauf von: Daniel
Geschrieben am: 11.08.2014 16:34:09

Hi

du siehst doch schon rein optisch, dass die Näherungsformel dir keine besonders guten Zwischenwerte liefern wird.

mit der Liniaren Interpolation hast du hier wesentlich bessere Ergebnisse:
=SVERWEIS(C14;C4:D11;2;1)+(INDEX(D4:D11;VERGLEICH(C14;C4:C11;1)+1)-SVERWEIS(C14;C4:D11;2;1))*(C14-SVERWEIS(C14;C4:C11;1;1))/(INDEX(C4:C11;VERGLEICH(C14;C4:C11;1)+1)-SVERWEIS(C14;C4:C11;1;1))

Gruß Daniel


 

Beiträge aus den Excel-Beispielen zum Thema "Formel Preisverlauf"