Microsoft Excel

Herbers Excel/VBA-Archiv

Wert zu Wert suchen

Betrifft: Wert zu Wert suchen von: Nicolai Nübel
Geschrieben am: 12.08.2014 13:59:59

Hallo zusammen,

in Spalte stehen Änderungsnummern. Mehrfachnennungen sind hier möglich, aber nicht zwingend. In B stehne Zahlen zwischen 0-9.

Ich möchte nun wissen, ob zur Änderungsnummer aus A in B irgendwo eine "1" steht.
Kann ich das in C auswerten?

Danke für Eure Hilfe.

https://www.herber.de/bbs/user/92043.xlsx

  

Betrifft: z.B. mit ZÄHLENWENNS() ... von: neopa C (paneo)
Geschrieben am: 12.08.2014 14:15:53

Hallo Nicolai,

.. in C3:

=ZÄHLENWENNS(A$2:A$99;A2;B$2:B$99;1)>0 
und nach unten kopieren.


Gruß Werner
.. , - ...


  

Betrifft: AW: z.B. mit ZÄHLENWENNS() ... von: Nicolai Nübel
Geschrieben am: 12.08.2014 14:43:01

Hallo Werner,

danke für deinen Tipp, leider ist das nicht ausreichend.
Wie du im Bsp. sehen kannst, kommt die Änderungsnummer: 19998538-R05
in Spalte A dreimal vor.
Ich möchte wissen, ob ich zu jeder Änderungsnummer mindestens einmal die 1 in B stehen habe.
Dies ist mein Indikator für weiterführende Maßnahmen.


  

Betrifft: und genau das tut mE die Formel, ... von: neopa C (paneo)
Geschrieben am: 12.08.2014 15:45:11

Hallo Nicolai,

... hast Du die Formel auch nach unten kopiert? Aus meiner Sicht tut sie genau das, was Du bisher beschrieben hast:

 ABC
1Änderungs-Nr.Differenz
Q-Infosatz & Revision
[ Erwartungswert: 1]
Auswertung
219998538-R050WAHR
319998538-R052WAHR
419998538-R051WAHR
520201038-R032FALSCH
620201038-R035FALSCH
720201038-R034FALSCH
847114711-R080WAHR
947114711-R081WAHR
10   

Formeln der Tabelle
ZelleFormel
C2=ZÄHLENWENNS(A$2:A$99;A2;B$2:B$99;1)>0


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Werner
.. , - ...


  

Betrifft: AW: z.B. mit ZÄHLENWENNS() ... von: Spenski
Geschrieben am: 12.08.2014 15:53:30

Hi

die Frage ist doch mit Werners Formel erfüllt.


meinst du evtl so??

C2=WENN(ZÄHLENWENNS(A$2:A$99;A2;B$2:B$99;1)>0=WAHR;1;0) RUNTERKOPIEREN

ausgabe ob alles ok bz erfüllt ist F1=WENN(MITTELWERT($C$2:$C$99)=1;"Alles Ok";"Nicht Ok")

wenn nicht schreib noch mal in dein beispiel wie das ergebnis aussieht...alles andere ist rumgerate


gruss


 

Beiträge aus den Excel-Beispielen zum Thema "Wert zu Wert suchen"