Microsoft Excel

Herbers Excel/VBA-Archiv

SVERWEIS mit Höchstwert

Betrifft: SVERWEIS mit Höchstwert von: Markus
Geschrieben am: 22.08.2014 09:28:16

Hallo und Guten Morgen
in einer Tabelle mit Geräte-Nr. und PKW-Bezeichnung soll Excel die notwendigen Daten aus der Tabelle2 ziehen.
Dabei können in der DatenTabelle (Tabelle2) mehrere Datensätze vorkommen.
Schlüsselfelder sind die Geräte-Nr. und der Vertragsbeinn (Höchstwert).
Es können pro Gerät mehrere Verträge vorkommen (bis etwa 20 Stück).
Analog sollen die Felder
Nutzer, Erstellt am, Unterzeichnet am, Weitergeleit am, Endet am automatisch gefüllt werden.
Danke für eine Hilfestellung
Markus

https://www.herber.de/bbs/user/92231.xlsm

  

Betrifft: AW: SVERWEIS mit Höchstwert von: Klaus M.vdT.
Geschrieben am: 22.08.2014 10:22:27

Hallo Markus,
bitteschön:
https://www.herber.de/bbs/user/92235.xlsm

Grüße,
Klaus M.vdT.


  

Betrifft: AW: SVERWEIS mit Höchstwert von: Markus
Geschrieben am: 22.08.2014 11:06:35

Hallo Klaus
fast sensationell!
Wie kann ich noch den #NV in der Matrix-Klausel vermeiden.
Es soll einfach nichts anzeigen, wenn kein Wert vorhanden.
Bei der Formel:
VERWEIS(2;1/(PKW_Vertraege!A:A&PKW_Vertraege!C:C=A2&F2);PKW_Vertraege!B:B) für den Namen
hab ich es mit einer Zählenwenn-Formel hingekriegt.
Wie aber kann ich es bei der Matrix-Formel vermeiden, dass #NV nicht angezeigt wird.
Danke
Markus


  

Betrifft: probier: =WennFehler(Formel;"") kwT von: Matthias L
Geschrieben am: 22.08.2014 11:13:09




  

Betrifft: AW: SVERWEIS mit Höchstwert von: Klaus M.vdT.
Geschrieben am: 22.08.2014 12:44:21

Hallo Markus,

Wie aber kann ich es bei der Matrix-Formel vermeiden, dass #NV nicht angezeigt wird
um zu vermeiden dass #NV nicht angezeigt wird musst du gar nichts machen :-) Ich kann den Fehler nicht nachvollziehen, im Falle einer fehlenden Gerätenummer liefert mir die Matrixformel eine 0 (bzw. einen 0.1.1900 aufgrund der Formatierung als Datum). Ich nehme an, dass meinst du (die anderen Formeln ergeben dann #NV)

Tausche E2 gegen:
{=WENN(ZÄHLENWENN(Tabelle2!$A$1:$A$1000;A2)=0;"-";MAX(WENN(Tabelle2!$A$1:$A$1000=A2;Tabelle2!$B$1:$B$1000)))}


alle anderen Formeln lässt du beginnen mit =WENN(E2="-";"-";formel)

Matthias, das WennFehler() führt hier zu nichts. Durch das Matrix-MAX wird die Formel zu Null ausgewertet, daher zieht WENNFEHLER nicht.

Grüße,
Klaus M.vdT.


  

Betrifft: Wieso? WennFehler ist doch genau richtig von: Matthias L
Geschrieben am: 23.08.2014 12:15:14

Hallo Klaus

Zitat

Matthias, das WennFehler() führt hier zu nichts. Durch das Matrix-MAX wird die Formel zu Null ausgewertet, daher zieht WENNFEHLER nicht.

Wenn Markus schreibt das er #NV in einer Zelle stehen hat
dann glaube ich ihm das so erst Mal, ohne mir eine Datei runterzuladen.
Sollte also #NV in der Zelle als Formelergebnis stehen dann geht WennFehler schon.
Deshalb mein Betreff-Text

Gruß Matthias


 

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS mit Höchstwert"