Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema ListBox
BildScreenshot zu ListBox ListBox-Seite mit Beispielarbeitsmappe aufrufen

Zellvergleich mit Matrix; Ergebnis teils Farbe?

Betrifft: Zellvergleich mit Matrix; Ergebnis teils Farbe? von: Günter
Geschrieben am: 22.08.2014 19:48:05

Hallo,

Ich vergleiche zwei Tabellenbereiche mit einer Wenn-Matrix.
Wenn das Ergebnis -Nicht ok- ist, wäre es vorteilhaft, wenn
das -Nicht- in einer Warnfarbe dargestellt würde.
Die Matrixformel war leicht durch Google zu finden, aber was man an der
Formel, außer dem Text überhaupt ändern darf oder kann, ist mir schleierhaft.
Und wenn, ist das evtl. mit zusätzlicher -bedingter Formatierung- machbar?
Würde mich über Hilfe freuen!

https://www.herber.de/bbs/user/92244.xls

Gruss,
Günter

  

Betrifft: AW: Bedingte Formatierung sollte reichen oT von: JoWE
Geschrieben am: 22.08.2014 19:58:00




  

Betrifft: AW: Zellvergleich mit Matrix; Ergebnis teils Farbe? von: Hajo_Zi
Geschrieben am: 22.08.2014 20:02:08

Hallo Günter,


Tabelle1

 H
1 
2 
3 
4 
5 
6 
7 
8 
9 
10 
11 
12 
13Keine Aktivität
14 
15nicht OK
Bedingte Formatierung Fülleffekte, Symbole, Farbskalen
werden in dieser Tabelle nicht dargestellt

verwendete Formeln
Zelle Formel Bereich N/A
H13{=WENN(UND(B11:B23=C11:C23);"Keine ";"")&"Aktivität"}$H$13 
H15{=WENN(UND(B11:B23=C11:C23);"nicht ";"")&"OK"}$H$15 
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!


Bedingte Formatierung Haupttabelle 1  
Zelle   Nr. Bed.  Regeltyp  Operator   Formel1   Formel2   Format Schrift Füllfarbe   Unterstrichen   Schrift- farbe Muster   Musterfarbe Typ Bereich
$H:$H01.Bed.: Zellwert istgleich="nicht OK"  255         1H:H
$H:$H02.Bed.: Zellwert istgleich="keine Aktivität"  255         1H:H
Bedingte Formatierung Haupttabelle 2 oberere/unterer Bereich    
Zelle   Nr. Bed.  Format Zelle Anhalten Auswahl   Anzeige   Anzahl   Durchschnitt   Typ   Bereich
$H:$H01.Bed.   Wahr          1H:H
$H:$H02.Bed.   Wahr          1H:H
Die Bedingungen wurden mit Excel-Version ab 2007 ausgelesen.

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.13 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: Zellvergleich mit Matrix; Ergebnis teils Farbe? von: Günter
Geschrieben am: 23.08.2014 15:03:47

Hallo,

Danke für die Vorschläge.
Bedingte Formatierung scheint die Lösung zu sein.
Dank an Hajo für die perfekte Beschreibung.
Damit Thema erledigt.

Bis demnächst,
Günter


  

Betrifft: Zellvergleich, neues WENN-Problem von: Günter
Geschrieben am: 28.08.2014 02:35:07

Hallo,

habe neues Problem mit diese Formel, aber nicht mehr mit der Formatierung.
Und zwar müsste noch eine weitere Zelle als Kriterium in die WENN-Matrix-Formel mit rein,

Grübel und probier schon den ganzen Tag, geht nix, und auch Excel gibt mir
keine passende "Fehlerkorrektur" :(
Wäre super, wenn mal jemand drüberschaut, und vieleicht eine Lösung findet.

https://www.herber.de/bbs/user/92335.xls

Bis bald,
Günter


  

Betrifft: AW: Zellvergleich, neues WENN-Problem von: Hajo_Zi
Geschrieben am: 28.08.2014 06:06:33

Halo Güntem,

Und(A1=4;DieFormel)

Gruß Hajo


  

Betrifft: AW: Zellvergleich, neues WENN-Problem von: Günter
Geschrieben am: 28.08.2014 14:41:52

Hallo,
mach ich da was falsch?

Die Formel,
{=UND(B5=0;WENN(UND(B11:B23=C11:C23);"Keine ";"")&"ZuWaage:")}
ergibt #WERT!

#WERT! bekomme ich irgendwie nicht weg.

Gruss,
Günter


  

Betrifft: AW: Zellvergleich, neues WENN-Problem von: Hajo_Zi
Geschrieben am: 28.08.2014 15:45:06

Hallo Günter,

ging es nicht um bedingte Formatierung?
Da gibt es keine Array Formeln, soweit mir bekannt. Ich bin aber nicht der Formelmensch.

Gruß Hajo


  

Betrifft: AW: Zellvergleich, neues WENN-Problem von: Günter
Geschrieben am: 28.08.2014 17:00:40

Hallo Hajo,

Die bedingte Formatierung funktioniert, dank deiner Hilfe bestens !
Wollte, wo ich diese Formel schon mal hier hochgeladen habe,
kein neues Thema aufmachen.(Neuer Betreff!)
Und somit die Zeit noch nutzen, bevors ins Archiv geht.
Die Logik von solchen Formeln hat sich mir bisher nicht erschlossen,
und darum eigentlich ein verzweifelter Versuch, bevor ich
versuchen muss, es auf andere Weise zu lösen, oder eben aufgeben muss.

Gruss,
Günter


 

Beiträge aus den Excel-Beispielen zum Thema "Zellvergleich mit Matrix; Ergebnis teils Farbe?"