Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Userform
BildScreenshot zu Userform Userform-Seite mit Beispielarbeitsmappe aufrufen

Daten filtern

Betrifft: Daten filtern von: Roland Weidenbach
Geschrieben am: 24.08.2014 16:16:49

Hallo liebes Forum,
ich rätsele schon länger an einem Problem: Ich habe für meine diabeteskranke Frau eine einfache Protokollierung ihrer Zuckerwerte und weitere Angaben geschrieben. Die Eingabe erfolgt mittels Userform mit den Funktionen eintragen, Übersicht drucken, speichern etc. Das Userform ist dabei so aufgebaut, dass Datum und Uhrzeit bei der Erfassung automatisch in die Spalten A und B eingetragen werden. Blutzuckermessungen finden mindestens 3 mal täglich statt. Es ist aber möglich, dass öfter oder evtl. mal seltener gemessen wird. Die klappt in soweit ganz gut. Nun möchte ich ein Liniendiagramm mit den Werten einer Woche generieren. Die Beschriftung sollte dabei das TAgesdatum nur einmal enthalten und dann jeweils die Werte für die Uhrzeiten. Läst sich die Tabelle dahingehend filtern? Ausblenden von doppelten Werten geht nicht, da ja sonst nur der zeitlich erste Wert eines Tages in der Tabelle erscheint. Oder gibt es die Möglichkeit, bereits beim Eintrag via Textbox das Problem abzufangen? ICh denke da evtl. eine Abfrage, wenn das Datum (derzeit TEXTBOX=DATE)vorhanden ist, dann leer lassen?
PS.: Das Diagramm erzeuge ich derzeit manuell.

  

Betrifft: AW: Daten filtern von: Gerold
Geschrieben am: 24.08.2014 17:23:40

Hallo Roland

Vieleicht so?
Mit einer zweiten Spalte für das Datum


Tabelle1

 ABCD
6Datum 1Datum 2ZeitWert
724.08.201424.08.201411:001
824.08.2014 12:002
924.08.2014 13:003
1025.08.201425.08.201411:004
1125.08.2014 12:005
1225.08.2014 13:006
1326.08.201426.08.201411:007
1426.08.2014 12:008
1526.08.2014 13:009

Formeln der Tabelle
ZelleFormel
B7=A7
B8=WENN(A8=A7;"";A8)
B9=WENN(A9=A8;"";A9)
B10=WENN(A10=A9;"";A10)
B11=WENN(A11=A10;"";A11)
B12=WENN(A12=A11;"";A12)
B13=WENN(A13=A12;"";A13)
B14=WENN(A14=A13;"";A14)
B15=WENN(A15=A14;"";A15)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Gerold

Rückmeldung wäre nett.


  

Betrifft: AW: Daten filtern von: Roland Weidenbach
Geschrieben am: 27.08.2014 09:51:57

Hallo Gerold,

Es kann manchmal so einfach sein... vielen Dank. Werde es gleich mal ausprobieren.


  

Betrifft: AW: Daten filtern von: Gerold
Geschrieben am: 24.08.2014 17:24:36

Hallo Roland

Vieleicht so?
Mit einer zweiten Spalte für das Datum


Tabelle1

 ABCD
6Datum 1Datum 2ZeitWert
724.08.201424.08.201411:001
824.08.2014 12:002
924.08.2014 13:003
1025.08.201425.08.201411:004
1125.08.2014 12:005
1225.08.2014 13:006
1326.08.201426.08.201411:007
1426.08.2014 12:008
1526.08.2014 13:009

Formeln der Tabelle
ZelleFormel
B7=A7
B8=WENN(A8=A7;"";A8)
B9=WENN(A9=A8;"";A9)
B10=WENN(A10=A9;"";A10)
B11=WENN(A11=A10;"";A11)
B12=WENN(A12=A11;"";A12)
B13=WENN(A13=A12;"";A13)
B14=WENN(A14=A13;"";A14)
B15=WENN(A15=A14;"";A15)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Gerold

Rückmeldung wäre nett.


 

Beiträge aus den Excel-Beispielen zum Thema "Daten filtern"