Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwertwenn

Betrifft: Mittelwertwenn von: Peter Weber
Geschrieben am: 26.08.2014 15:39:16

Hallo Zusammen,

ich möchte einen Mittelwert über einen Spaltenbereich erstellen.
Leider sind in der Spalte #NVs.

Wie kann man trotz der #NVs einen Mittelwert bilden.

Die Formel:
=MITTELWERTWENN(D34:D706;C6;F34:F706)
liefert #NV.

Für eure Hilfe bedenke ich mich im voraus.
LG, Peter

  

Betrifft: AW: Mittelwertwenn von: Klaus M.vdT.
Geschrieben am: 26.08.2014 15:44:34

Hallo Peter,
{=MITTELWERT(WENN((C34:C706=B6)*NICHT(ISTFEHLER(F34:F706));F34:F706;""))}
Matrixformel! {} nicht mit eingeben, sondern durch Abschluss der Formel mit STRG+SHIFT+ENTER erzeugen.

Grüße,
Klaus M.vdT.


  

Betrifft: Sorry - C6, nicht B6 von: Klaus M.vdT.
Geschrieben am: 26.08.2014 15:45:38

Sorry, zu schnell auf "absenden" gelickt.
so ist es richtig:
{=MITTELWERT(WENN((C34:C706=C6)*NICHT(ISTFEHLER(F34:F706));F34:F706;""))}
Matrixformel! {} nicht mit eingeben, sondern durch Abschluss der Formel mit STRG+SHIFT+ENTER erzeugen.

Grüße,
Klaus M.vdT.


  

Betrifft: AW: Mittelwertwenn von: Peter Weber
Geschrieben am: 26.08.2014 16:21:50

Hallo Klaus,

vielen Dank für deine Antwort.

So funtioniert der Mittelwert.

LG, Peter


  

Betrifft: Danke für die Rückmeldung! owT. von: Klaus M.vdT.
Geschrieben am: 27.08.2014 07:41:08

.