Microsoft Excel

Herbers Excel/VBA-Archiv

Makro für Auswertung aus Datenbank

Betrifft: Makro für Auswertung aus Datenbank von: walter mb
Geschrieben am: 28.08.2014 10:31:01

Guten Morgen zusammen,
anbei meine Musterdatei.
In der Tabelle Auswertung sind die Begriffe in der Spalte A ab A1
eingetragen.
Hier soll in der Spalte "B" jeweils die Anzahl wie die Texte in der
Spalte "B" ab B3 vorkommen.
https://www.herber.de/bbs/user/92347.xlsx
mfg
walter mb

  

Betrifft: Zählenwenn ohne Makro von: ChrisL
Geschrieben am: 28.08.2014 11:17:11

Hi Walter

Braucht es wirklich ein Makro? ;)

=ZÄHLENWENN(Datenbank!B:B;A2)

cu
Chris


  

Betrifft: Hallo Chris von: Walter mb
Geschrieben am: 28.08.2014 14:42:07

Hallo Chris
danke.
Ich werde es mit der Formel gleich testen.
Dich aber noch was lernen möchte, wollte ich dies mit einem Makro
lösen.
Gruß
Walter mb


  

Betrifft: AW: Hallo Chris von: hary
Geschrieben am: 28.08.2014 16:32:05

Moin Walter
Auch mit Zaehlenwenn.

Dim i As Long
With Worksheets("Auswertung")
  For i = 2 To .Cells(Rows.Count, 1).End(xlUp).Row
                             '=ZÄHLENWENN(Datenbank!B:B;A2)
   .Cells(i, 2) = Application.CountIf(Worksheets("Datenbank").Columns(2), .Cells(i, 1))
  Next
End With

gruss hary


  

Betrifft: Danke an Chris und Hary von: walter mb
Geschrieben am: 28.08.2014 18:17:28

Herzlichen Dank !!!


 

Beiträge aus den Excel-Beispielen zum Thema "Makro für Auswertung aus Datenbank"