Microsoft Excel

Herbers Excel/VBA-Archiv

Spaltenwerte addieren

Betrifft: Spaltenwerte addieren von: Peter Weber
Geschrieben am: 01.09.2014 15:05:26

Hallo Zusammen,

ich stehe ein wenig auf dem Schlauch.

In der Zeile 10, ab Spalte C, stehen meine Monatswerte.

In der Zeile 13 möchte ab Spalte C, die Werte der Zeile 10 aufsummieren.
Soweit kein Problem.

Nun möchte ich aber die Formel nach rechts kopieren aber so, dass nach 12 Monaten die Aufsummierung wieder mit Januar anfängt.

Wie könnte ich das mit Excel am elegantesten lösen?

Für jeden Vorschlag bedanke ich mich bei Euch im voraus
LG, Peter

  

Betrifft: kannst Du bitte ein Bsp zeigen? owT von: Matthias L
Geschrieben am: 01.09.2014 15:14:36




  

Betrifft: AW: Spaltenwerte addieren von: Rudi Maintaire
Geschrieben am: 01.09.2014 15:17:57

Hallo,
sowas?

CDEFGHIJKLMNOPQRSTUVW
9Jan 14Feb 14Mrz 14Apr 14Mai 14Jun 14Jul 14Aug 14Sep 14Okt 14Nov 14Dez 14Jan 15Feb 15Mrz 15Apr 15Mai 15Jun 15Jul 15Aug 15Sep 15
10111111111111111111111
11                     
12                     
13123456789101112123456789

ZelleFormel
C13=SUMMENPRODUKT((JAHR($C9:C9)=JAHR(C9))*$C10:C10)
D13=SUMMENPRODUKT((JAHR($C9:D9)=JAHR(D9))*$C10:D10)


Gruß
Rudi


  

Betrifft: AW: Spaltenwerte addieren von: Peter Weber
Geschrieben am: 01.09.2014 15:40:11

Hallo Rudi,

vielen herzlichen Dank für die Lösung.

Es ist genau das was ich gesucht habe.

Lg, Peter


 

Beiträge aus den Excel-Beispielen zum Thema "Spaltenwerte addieren"