Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis matcht falsch

Betrifft: Sverweis matcht falsch von: henrik
Geschrieben am: 01.09.2014 17:09:29

Hi zusammen,

ich habe 2 Listen. In Liste A steht nur die Artikel Nr. In Liste B stehen Artikel Nr und Status. Jetzt möchte ich mir an die Artikel Nr. aus A die Stati aus B schreiben. Matchen tue ich mit Sverweis über Artikel Nr.

https://www.herber.de/bbs/user/92424.xlsx

Das Problem ist jetzt, dass der Sverweis nicht richtig match. Bsp:

Artikel Nr "1100M22" gibt es in Liste A. In Liste B gibt es sie nicht. Excel schreibt mir aber trotzdem eine "1" hinter die Artikel Nr in Liste A. Eigentlich müsste er aber ein "#NV" setzen, da die Nummer nicht in Liste B vorhanden ist.

Was ist das? Finde das extrem merkwürdig...

Need Help!

  

Betrifft: AW: Sverweis matcht falsch von: stef26
Geschrieben am: 01.09.2014 17:14:05

Hi,
du musst den Wahrheitswert auf falsch stellen, dann werden nur die 100% übereinstimmenden Ergebnisse angezeigt...


Stefan


  

Betrifft: AW: Sverweis matcht falsch von: Hajo_Zi
Geschrieben am: 01.09.2014 17:15:32

Du solltest den 4 Paramter auch angeben. Sverweis sucht auch in ausgeblendeten Zeilen.=SVERWEIS(A59;E:F;2;0)

GrußformelHomepage


  

Betrifft: AW: Sverweis matcht falsch von: hary
Geschrieben am: 01.09.2014 18:12:47

Moin
Wie Hajo schreibt, SVerweis nimmt auch die ausgeblendeten Zellen mit.
Hier mal eine UDF.
Code in ein Modul.

Public Function SVZwei(SuchBereich As Range, Suchstring As String)
Dim gefunden As Range
Set gefunden = SuchBereich.Find(what:=Suchstring, LookAt:=xlWhole, LookIn:=xlValues, MatchCase:= _
True)
If Not gefunden Is Nothing Then
   SVZwei = gefunden.Offset(, 1)
Else
   SVZwei = "nicht da"
End If
End Function

Aufgerufen durch Benutzerdefenierte Formel.



Tabelle1
 ABC
1451100M221nicht da

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
B145=SVERWEIS(A145;E:F;2;)  =VLOOKUP(RC[-1],C[3]:C[4],2,)
C145=SVZwei(E:E;A145)  =SVZwei(C[2],RC[-2])

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary


 

Beiträge aus den Excel-Beispielen zum Thema "Sverweis matcht falsch"